View Full Version : Help with AirBag Error 2005 745li

09-20-2012, 09:22 AM

I recently had the driver side seat error pop up on the dashboard. I cleared all the codes and it didn't come back for a few weeks. I noticed it recently its started to come back every 5 days. I have managed to pinpoint the error in INPA to the drivers seat. Once you clear the error the light goes off. Here is a pic of the error. Please can someone help and establish what possibly needs to be replaced or done to resolve the issue.



PS is this possibly related to this http://www-odi.nhtsa.dot.gov/cars/problems/recalls/recallsummary.cfm?rcl_campaign_id=08V384000&prod_id=113225&moduletype=VEHICLE&make=BMW&model=5%20SERIES&veh_model_year=2004&searchtype=DrillDown

09-20-2012, 10:03 AM
is it one of these possible sensors http://www.realoem.com/bmw/showparts.do?model=GN63&mospid=47785&btnr=65_1143&hg=65&fg=65

09-20-2012, 11:04 AM
Sometimes it isn't the sensor. I've had a few that we had to clip and replace the connector

Sent from my AT100 using Bimmer App

09-20-2012, 12:03 PM
thanks, I will check the connector. Is it the one going from the mat sensor ?

09-20-2012, 12:24 PM
the harnesse side, going to the module for me. "Experiences may vary"

09-26-2012, 01:46 AM
Just to add I did some test on INPA on the seat mat and I received an open circuit error. Does this mean the mat needs to be replaced ?

09-26-2012, 10:54 AM
Keep in mind, most likely is the Passenger seat mat sensor , and it is covered under warranty since you vehicle is a 2005 , just had mine replaced under warranty and i believe all 7 series from years 05 up there's a 10 years warranty on this specific part .

09-26-2012, 02:26 PM
Just spoke to BMW Canada, they have acknowledged and confirmed that it is covered. Got it booked in next week see if they honor it. I just had the passenger side go red on the airbag. Checked it with INPA and shows communication error and open circuit.