PDA

View Full Version : a few possible electrical problems we have come across...


boxtree619
09-25-2012, 09:39 PM
So about four months ago, I made an account on here and introduced myself when my father and I picked up his new-to-him E66 745li (it's basically brand new being that its a 2003 with ~30k miles when we picked it up:thumbup:). It has proven to be quite a nice vehicle for him and he has enjoyed every moment he's driven it. We've even taken it on a 1300mile road trip all around the state of Arizona and powertrain-wise, it has proven to be quite reliable and powerful.

However, there are a few possible ELECTRICAL problems we have come across these past few months.

A week after we purchased the vehicle, we noticed that the power window switch on the front passengers side does not lower the front passenger window. However, the front passenger window rolls down just fine when you use the drivers side window controls. But the trippy part is that the front passenger side window switch can raise the window up. In a nutshell, the front passenger side window switch does not lower the front pass side window, but only raises it and to lower it, the drivers side window switch must be used.

In addition to the aforementioned problem, our radio no longer works anymore. I can still navigate through the iDrive options, however the radio itself does not work anymore, even after clicking the little black radio knob down as if I was going to turn it on.

Any idea what could be the cause of this problem? Any help would be greatly appreciated.

Thanks :)

Oh..and here's a photo of the farthest point in our trip along with the map if any of you are interested. This was taken just 40 or so miles shy of the New Mexico border at the Petrified Forest National Park. I had to take this picture quick before the park ranger noticed I backed up off the road :rofl:
https://sphotos-b.xx.fbcdn.net/hphotos-snc7/399710_4393262239994_523999520_n.jpg
https://sphotos-b.xx.fbcdn.net/hphotos-ash4/250343_4393569727681_1525598870_n.jpg

Mr.750
09-26-2012, 02:18 PM
Front passenger window, I have no idea. But I am guessing that it would be easier just to ask the driver to mess with it than go to the stealership and pay them a horrendous amount to fix it. And with the radio check your tone and try adjusting that. Also try using different CD's and not just the radio. Not sure if it will help but good luck! :thumbup:

csmeance
09-26-2012, 02:26 PM
The easiest solution to try is the MOST BUS reset procedure. It's posted here in detail on how to perform but essentially it'll reset all the modules and you'll start off from a clean slate!

OrgBimmerDude
09-26-2012, 02:40 PM
Also, just a thought, it could be your ASK unit going bad or gone bad... Check that out as well... its not a serious issue, but annoying one for sure... GOOD LUCK

Expo BMW
09-26-2012, 06:46 PM
Check ebay for a passenger window switch replacement. For the radio issue refer to the two posts above mine.

boxtree619
09-30-2012, 01:26 AM
ok just a lil update..

I looked up the MOST BUS reset procedure and did it just now and it did not work. When I drove it earlier today, I realized that not only is the radio not working (my stations don't show or anything..), but the navigation does not work as well.

I'll have to look into checking out the ASK unit next when I have the time.

dannyb1027
09-30-2012, 05:43 AM
For the P/S window I say it's a switch because you know the motor and regulator is working fine. I've been having a few problems with my audio system and was able to reset it by disconnection the battery cables and connecting them together for 30 mins. I use long screwdriver to connect the two. it worked for me with positive results.