PDA

View Full Version : Bmw Assist Problem!


the worm
12-21-2004, 10:46 AM
I picked up my 05 X3 about a month ago. They didn't test the assist at the dealer because it was "too new". I finally got my assist info in the mail and tested it out only to find out that it doesn't work! :thumbdwn:

I spoke to the assist folks vai landline and they said they could hear me but I never could hear them and they said you have to take it into the dealer. I took it in after a full day they call me back and say they don't know what it is. 2 (business) days later now and they still don't know the problem and because of the Holidays can't get my car in until 05 and need it for up to 2+ days and have no loaner.... what's up with that BMW! :dunno:

Anyone else have assist problems?

xspeedy
12-21-2004, 10:50 AM
I tested mine well before I needed to take a road trip. Maybe you don't have Verizon coverage where you are?

the worm
12-22-2004, 01:32 PM
I tested mine well before I needed to take a road trip. Maybe you don't have Verizon coverage where you are?

I am in the Bay Area so I would find that hard to believe but is it true it only works where Verizon has coverage?

the worm
01-06-2005, 04:32 PM
BMW has now had my car for 4 days hope to have it back to me tomorrow. They say they are replacing the unit. :thumbdwn:

harplayr
01-07-2005, 05:40 AM
I tested mine well before I needed to take a road trip. Maybe you don't have Verizon coverage where you are?It doesn't sound like a lack of coverage as the Assist station was able to hear him so a connection was made.

sfca-325i
01-07-2005, 10:21 AM
Poor predelivery by the dealership.

When we picked up our X3 from Allison (now BMW of Mountain View), the salesperson wanted to show us how Assist worked. Pressed the button and nada. Turned out, they hadn't activiated Assist.

Took an extra 30 minutes to get the car but they got everything right.