PDA

View Full Version : Burning Smell From My New X3..Help...


ICEBERG
03-18-2005, 08:46 PM
Hi guy's

My X3 just came in today. Wonderfull car. But i noticed a burning rubber smell when i got it home and parked in the garage.

The car has only 50km on it. When i took delivery it had only 9km. When i took it home it smelled like burning plastic bag from the engine.

Should i be worried? Is it very new and thats why it is doing this?

Any info would be great.

P.S it is a step auto. So it is not the clutch.

ICEBERG
03-18-2005, 08:59 PM
The car is only 5 hours old before this happened. Also i was doing highway driving home at about 100km/h but i never went over 3500 rpm. So worried, hope nothing serious.

xspeedy
03-18-2005, 09:13 PM
It is probably just cosmoline burning off the undercarriage.

tonymey
03-19-2005, 09:15 AM
I notice this too after I parked my X3, so I'm not crazy,, thanks for the post. It's probably just "new" sfuff burning away, I would not worry about it too much unless you start to see smoke :yikes:

ICEBERG
03-19-2005, 03:27 PM
Thank's guys.

The smell went away today. :thumbup: Hope it will stay away. No smoke.

Love this car though. Drives great. Corners good as my C230. No rattles or shakes. Solid as a rock so far.

Will post pics. when i have time.

iChick
03-19-2005, 05:33 PM
Thank's guys.

The smell went away today. :thumbup: Hope it will stay away. No smoke.

Love this car though. Drives great. Corners good as my C230. No rattles or shakes. Solid as a rock so far.

Will post pics. when i have time.

Mine had that smell after its first trip "home". Went away after a day or two.

craigmack1
11-06-2011, 04:36 PM
Any follow up info on this "burning smell" issue. when my wife parks the car in the garage you can smell something burning. i drove it today and noticed the smell is in the cabin when at a light or something but kind'a fades away as you drive. it it much more noticeable now that we are using the heat in the car instead of the air.

no leaks
99k

stumped!

mlukas161
11-06-2011, 05:50 PM
This burning smell is almost definitely the valve cover gasket leaking. Its a rubber gasket that gets dry with age and allows small amounts of oil to escape and burn on the headers. It's a common problem. A pretty easy DIY fix and parts are less that 75 dollars. Do a search and a lot of info will show up, mostly with the 3 series BMWs.

madurodave
11-06-2011, 05:54 PM
Any follow up info on this "burning smell" issue. when my wife parks the car in the garage you can smell something burning. i drove it today and noticed the smell is in the cabin when at a light or something but kind'a fades away as you drive. it it much more noticeable now that we are using the heat in the car instead of the air.

no leaks
99k

stumped!

Could've what I just had. I spilled a little oil at my last change. Must be on pipe below. Fading now. Took a while to fade.
Or could be leaking gasket or seal.

craigmack1
11-12-2011, 05:04 PM
thanks for the info guys. i am seeing some smoke so something is definitely leaking and burning off somewhere, and sounds like a good call on the valve cover gasket. i am going to get on that as soon as i can before oil gets down into one of the pistons!

fivepointnine
11-14-2011, 10:22 AM
a valve cover gasket leak will drip right down by the rear O2 sensor (on mine at least) and will smell with the head on at idle. my VCG had 67k on it and when I pulled it off it was no longer rubber, it was almost like brittle plastic! takes about 2 hours and is a very very easy job, all the gaskets and grommets were about $70 from my local BMW dealer. BTW I had 0 sludge in the head!!!! (just a little crust on the inside of the valve cover)

Martin5333
11-14-2011, 11:44 AM
Guys this is what exactly happened this morning with my X3. Every once in a while I see a bit of smoke out the motor compartment and by inspecting i can tell there is a bit of oil under the valve cover gasket that is burning out....I`m not sure if due to oil spil during the fill or dry rubber gasket....Will see!

craigmack1
11-25-2011, 02:47 PM
well, i changed the valve cover gasket. it was brittle just like already described. i still am seeing and smelling some oil, but i just hope that it is just the loose oil burning off from doing the job. i will watch it for a few days. hopefully it will all burn off soon.