PDA

View Full Version : Help!!! My new X3 has Keyless Entry problem!!!


newbmer1
03-28-2005, 10:15 PM
I just got an X3 this month and I have already brought it back to the dealer twice b/c the keyless entry is working rather intermittently - and to my dismay, generally DOES NOT work in or near my house!!! But each time, it works fine at the dealership and I get a call from the mechanic saying it works "perfectly" and they apparently didn't do anything about it! But the minute I get home and test it, IT DOES NOT LOCK or UNLOCK unless I reach up w/ my arm and somehow put the key w/in an inch of the rear antenna!!!! I've never had this kind of nuisance before w/ my 4 other keyless cars and SUVs previously so I know I'm not entirely crazy or stupid!!!

Has anyone else had this kind of problem w/ intermittently functioning keyless entry on the X3 or has any ideas how to fix it? I'm hoping to convince the dealership I'm not crazy or if simply reprogramming it would somehow fix it? Any ideas? I really hope I would not have to drop my backpack and gym bag and bike shoes and tennis rackets each time I tried to lock the car, I will indeed go crazy if that's the case. Thanks for any help out there!!! :dunno:

ianrossip
03-29-2005, 12:16 AM
Hello, I have no problem with my X3 key but I saw a program on TV that talk about a place where a lot of keyless control didn't work all the time (car and gate), at the end they discovered that a neighbour had a system to send the TV audio and video signal on the air from a room to another of his house, and whed his system was operating the interference causes the malfunctionning of the remote controls. Maybe you have a similar problem, it could explain why by your dealership. Does it work in other places far from your house?

Ian

xspeedy
03-29-2005, 05:26 AM
Can you narrow it down to a particular key? Do both keys cause you this problem, or just one? Do you only have the problem at your house, or also at the office or the mall?

4everbavarian
03-29-2005, 08:27 AM
Not sure if your problem is exactly the same but found this on another forum:

http://bimmer.roadfly.org/bmw/forums/e83/6394319-1.html

Good luck.

ICEBERG
03-29-2005, 08:38 AM
I wonder if this problem is with the 2004 cars? I have the 2005 x3 and so far both keys work great. It works every where without any interference. Does the 05 models have this problem also? :dunno:

Tayrum
03-29-2005, 11:32 AM
I just got an X3 this month and I have already brought it back to the dealer twice b/c the keyless entry is working rather intermittently - and to my dismay, generally DOES NOT work in or near my house!!! But each time, it works fine at the dealership and I get a call from the mechanic saying it works "perfectly" and they apparently didn't do anything about it! But the minute I get home and test it, IT DOES NOT LOCK or UNLOCK unless I reach up w/ my arm and somehow put the key w/in an inch of the rear antenna!!!! I've never had this kind of nuisance before w/ my 4 other keyless cars and SUVs previously so I know I'm not entirely crazy or stupid!!!

Has anyone else had this kind of problem w/ intermittently functioning keyless entry on the X3 or has any ideas how to fix it? I'm hoping to convince the dealership I'm not crazy or if simply reprogramming it would somehow fix it? Any ideas? I really hope I would not have to drop my backpack and gym bag and bike shoes and tennis rackets each time I tried to lock the car, I will indeed go crazy if that's the case. Thanks for any help out there!!! :dunno:



I had a similar problem. Only one of my keys worked properly upon pick up of the vehicle and the sales person said it was most likely interference because of being right down in the city. When I got home it still did not work and I had to take it back the next day. What the service technician did was he held it up to the rearview mirror and pressed the buttons in a specific series and then it was reprogrammed. This may be all that is needed with yours.

Good luck!

jliu34740
03-29-2005, 03:11 PM
I have problems with my keys as well. It has only happened to me 3 times so far (over about a month). I can't remember if they were associated with one key or both keys (I use them both, to charge batteries). When it acts up, I can not open/close doors with remote (press button, nothing happens). Wait 1/2 to 1 hour, it would work fine again.

I KNOW this is a problem. But it hasn't bothered me enough to call dealer yet since I can not replicate it on demand. I have never had problems like this in my previous cars. I pretty much acknowledged the fact that I have to put up with little problems like this in exchange for better handling and design in a BMW. Too bad the germans don't know how to make it troublefree like the Japanese cars.