Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Members List

Supercourse Supercourse is offline

Officially Welcomed to the 'Fest

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. theturk9655
    03-15-2009 04:41 PM
    theturk9655
    yes it takes a few times of turning the ignition before it will fire up i had them check the fuel pump that seams okay changed the crank sensor so that's not it so i'm thinking maybe it's a bad relay(it seams to get worse as the day goes on one crank in the morning then more each time after) any ideas

About Me

  • About Supercourse
    Location
    British Columbia, Canada
    What I drive
    2004 X3 2.5i

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 05:56 AM
  • Join Date: 02-14-2008
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

All times are GMT -7. The time now is 07:04 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms