Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > Members List

youngest740ownr youngest740ownr is offline

Officially Welcomed to the 'Fest

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. ricknieves
    10-06-2009 12:19 PM
    ricknieves
    Hello sir I was just reading some of your post and I was wandering if you can help me, I have a 1994 525I that was over heating and after reading some info here and there, I want to change all of the temperature sensor/sender but my problem is that there are 2 on the engine that have same plug (12621747281 black & 13621709966 blue) but looking at the plug itself one have 2 wires coming from the engine harness and the other only one. I was wandering if you can determent witch one plug where? I appreciate in advance for all your help and trouble

    Sincerely

    Rick Nieves

About Me

  • About youngest740ownr
    Location
    portland, oregon
    What I drive
    2000 740il
  • Signature
    2000 740il ... black car, black leather, tinted windows....will be VIP'ed out

    1990 s13 drift car

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 06-04-2012 07:20 PM
  • Join Date: 08-19-2007
  • Referrals: 0

All times are GMT -7. The time now is 01:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms