Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E36 (1991 - 1999) (http://www.bimmerfest.com/forums/forumdisplay.php?f=97)
-   -   Acceleration misfire (http://www.bimmerfest.com/forums/showthread.php?t=112621)

rpburg 09-22-2005 11:03 PM

Acceleration misfire
 
Need help determining cause of misfire when accelerating at about 2000 rpm. The car is 98 323i manual transmission. Replaced plugs and still misfiring. Plugs removed were clean. Typically notice misfire/ lugging in 1st and 2nd gear. Raging in 3rd and 4th gear (high rpms) and car runs great. Anyone have a similar problem and fix it? I've read about everything from idle control valve to fuel pump to coils but no sure cure. :dunno:

rpburg 09-23-2005 06:32 PM

Went to independent today. Found an O2 sensor code (but check engine light not on). Sensor seemed to be functioning fine during idle. Plan is to see if I can get the code to reset again after driving car for the weekend and confirm the O2 fault. He also suggested it might be the air mass meter starting to go bad. The best thing... no charge unless he actually fixes something.

Anyone have an opinion?

screwuphead 09-23-2005 09:06 PM

i have the same problem and i am going ot change my fuel injectors ill tell you if that works!

G_VMP 09-29-2005 02:34 AM

The fuel injectors are definatly blocked by wat ive heard, ive knowen ppl with simular problems

frost_dxb 09-30-2005 12:22 AM

Quote:

Originally Posted by screwuphead
i have the same problem and i am going ot change my fuel injectors ill tell you if that works!


why change when you can always get that injectors serviced at less $$$?


All times are GMT -7. The time now is 09:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms