Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X3 E83 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=65)
-   -   Transmission Reprogram DIY (http://www.bimmerfest.com/forums/showthread.php?t=199388)

kjboyd 04-09-2007 04:37 PM

Transmission Reprogram DIY
 
Has anyone here tried this? seems like the 7er folks are getting good results... might just be that perticualr transmission though...

http://www.bimmerfest.com/forums/sho...d.php?t=195020

MJS 04-09-2007 05:11 PM

Interesting. Never heard of that one before. No 'big' complaints on the way my 2007 X3 shifts, so I'll pass on trying this one.

michaeloliverio 04-10-2007 05:17 PM

Worked in my '03 X5
 
Tried it this morning.
1 to 2 much crisper also 3 to 4 seemed better.
Mike

bigjakex3 04-10-2007 06:26 PM

My only complaint of the X3 is the start from dead stop where I think it goes from gear 2 down to gear 1. I tried it this morning but it didn't seem to help that. Anyone with info on reprograming the tranny to start in gear 1?

Thanks

Tlon 04-10-2007 06:42 PM

Quote:

Originally Posted by bigjakex3 (Post 2297522)
My only complaint of the X3 is the start from dead stop where I think it goes from gear 2 down to gear 1. I tried it this morning but it didn't seem to help that. Anyone with info on reprograming the tranny to start in gear 1?

Thanks

I'm not sure if it does the same thing with the X3, but I believe the Dinan Engine software for the E46 changed the transmission in the D setting to start in 1st gear instead of the normal 2nd gear. Of course, the S mode does the same thing. If it does work for the X3, it's an expensive solution.

http://www.dinancars.com/Series.asp?...is=36&Model=90

Brandon01 04-10-2007 10:03 PM

I tried it today and I think it made an improvement (although it might just be a placebo effect).

The procedure I followed:

1. Insert key and turn 2 clicks - accessories power on, dash lights illuminate.
2. Press gas pedal all the way to floor, past the click point.
3. Hold for 25 seconds.
4. Release gas pedal.
5. Turn engine on.

It feels much snappier accelerating from a dead stop, better throttle response, and better about shifting from 1 to 2. It feels more like driving in SD mode, just without extended rev holding. I need to drive for a couple of days to tell for sure.

I'm curious to hear from more people who try this. The trannies mentioned in the original posts on 5 and 7 series are ZF 6ATs I believe; we have GM sourced 6ATs. But I'd be willing to bet the procedure for clearing the adaptation was specified to be the same for all BMW ATs.

Can anyone provide hard confirmation on this?

JG 04-11-2007 05:20 PM

Quote:

Originally Posted by Brandon01 (Post 2297941)
I tried it today and I think it made an improvement (although it might just be a placebo effect).

The procedure I followed:

1. Insert key and turn 2 clicks - accessories power on, dash lights illuminate.
2. Press gas pedal all the way to floor, past the click point.
3. Hold for 25 seconds.
4. Release gas pedal.
5. Turn engine on.

It feels much snappier accelerating from a dead stop, better throttle response, and better about shifting from 1 to 2. It feels more like driving in SD mode, just without extended rev holding. I need to drive for a couple of days to tell for sure.

I'm curious to hear from more people who try this. The trannies mentioned in the original posts on 5 and 7 series are ZF 6ATs I believe; we have GM sourced 6ATs. But I'd be willing to bet the procedure for clearing the adaptation was specified to be the same for all BMW ATs.

Can anyone provide hard confirmation on this?


I would be interested to see if there is any substantial mileage change........

petren 04-12-2007 08:34 AM

Tried this yesterday and I was almost ready to reply with a note that nothing really changed but today I did make note of some changes. I drive every day over a bridge 1km long and 30% steep and every time I play with the SD in order to keep from changing gears uphill. Today after performing the procedure, I noticed the car didn't need that play and also it seems peppier at passing other cars or starting from a dead stop. Less gear change.

petren 04-12-2007 08:37 AM

As for mileage, one thing I noticed was that driving in SD in town seem better on the consumption and since the car seem to drive in SD type style after the procedure is done, it may have some minimal benefit but I don't expect wonders.

dgboggs 04-12-2007 01:21 PM

I can say that it certainly worked for my '06 X3. I bought it as a demo with 5k, and it shifted funny- late/hesitant changes. I tried the re-boot, and now this feels altogether different. Much peppier, easier to pass, and more economical. But, my car was a demo, and I think that it was driven by someone with a heavy foot.

crazybelgian 04-12-2007 01:39 PM

Same here, leasing a demo vehicle. Seems like it shifts better now, but I just reset it at lunch, haven't had enough time to really see if there is a difference...

MTLX3 04-12-2007 03:47 PM

Stupid question here, don't flame me :rolleyes: :
In the old days if you pressed on the gas pedal too long before starting you car, you would flood the engine and the car would stall... why is this not the case if you press on the gas pedal for 25 seconds and then start the engine? :dunno:

kjboyd 04-12-2007 03:48 PM

no "carbs"

MTLX3 04-12-2007 03:48 PM

Quote:

Originally Posted by kjboyd (Post 2302689)
no "carbs"

Ahhhhhhhh...:confused:

Brandon01 04-12-2007 04:00 PM

Ok, it's been 3 days now since I did the procedure and I've paid careful attention, counted shifts, and watched fuel consumption. I can say with certainty that it has changed how the car shifts, for the better.

I have a 2007 (build date Nov 06). When in D mode it suffered from annoying transmission lag, fumbling for gears, starting in 2nd then shifting down to 1st when accelerating from a stop. All the things many others have complained about with the 07 6AT. Things which driving in SD mode cured, but SD brings with it higher rev holding which is a bit too aggressive. I've said to my wife I wished there was a mode in-between.

I can confirm that in D mode now the car always starts in 1st. Under light acceleration it then quickly shifts to 2nd. No more fumbling, no more dropping from 2nd to 1st when starting from a stop. All I can say is "Yay!"

However, in my case mileage has dropped a little. I was expecting this, as starting from 2nd before should save some fuel. My average city mileage per the on-board computer (which I reset right after perfoming the procedure) has dropped from 16.8 to 15.8 over the same routes and streets as before. My highway mileage was about 23 before. I don't anticipate seeing a change there (can't say yet - no weekend trips). This is with 2800 miles on the car.

MTLX3 04-14-2007 09:37 PM

Tried the same procedure as you guys in my 2007 X3 loaner (mine should be approaching Canada any day now :clap: ) and I can't say I really noticed any difference...:( . I wish it did as I find myself using the SD mode quite often, specially around town. Will try again tomorrow, maybe I didn't do it right... but that would be surprising as it is a very simple procedure.

kjboyd 04-14-2007 11:17 PM

for the most part, gas mileage went DOWN for me.

r6girl 04-15-2007 08:34 AM

Quote:

Originally Posted by MTLX3 (Post 2302685)
Stupid question here, don't flame me :rolleyes: :
In the old days if you pressed on the gas pedal too long before starting you car, you would flood the engine and the car would stall... why is this not the case if you press on the gas pedal for 25 seconds and then start the engine? :dunno:

well, here goes with an explanation from years ago when my dad showed me around the cars he rebuilt as i was growing up, so this may not be completely technically correct...

in the past, carburetors were used to control the mix of gas and air pushed into the cylinders (where the gas & air mixture combusts with a spark from a spark plug, and cylinders combusting in turns rotates a crankshaft, etc.). they were mechanically controlled, so if you pressed the gas pedal, you could flood the carburetor with gas while the engine was not running, which would mess up the proportion of gas and air needed to properly combust in the cylinders, so the engine wouldn't start.

nowadays, carburetors have been replaced by electronic fuel inject (EFI) where the amount of gas forced into the cylinders is controlled electronically (and more precisely for better combustion). this electronic feature does not work when the ignition is off, so you if you press the gas pedal when the engine is not running, there is nothing to flood...

so there you have it... ;)

petren 04-17-2007 08:23 AM

More on this: (it will explain why for some, or some newer cars may not seem to make a difference)

According to my BMW buddy, the procedure is real for all current BMW's. The adaptive transmission is learning yor driving habits and and algorhitm is established but everything pretty much stops after the first 1000KM after which the learning is complete. Then, in order to make it learn again or reset, you need to perform this procedure again.

So, in my opinio it would make sense for dealers to also perform this procedure before a certified series is sold.

If a car (eg 2007 loaner) has less than 1000km on the odometer, the procedure will have no sensible effect.

But on my car which I purchased it as a Certified series at 25k km, it made a huge difference. As someone said, it feels like a totally new car. I used to read reviews that said the X3 3.0i had plenty of power and seem to have a pretty good transmission/engine match. Only now I completely agree with that comment, after performing that procedure.

crazybelgian 04-17-2007 08:48 AM

Quote:

Originally Posted by MTLX3 (Post 2302685)
Stupid question here, don't flame me :rolleyes: :
In the old days if you pressed on the gas pedal too long before starting you car, you would flood the engine and the car would stall... why is this not the case if you press on the gas pedal for 25 seconds and then start the engine? :dunno:

I'd say the simple answer is that the car is drive-by-wire... no mechanical connection between gas pedal and engine.
I don't think you can flood the engine at all because the computer wont let you, but I could be wrong of course...

uboat 06-12-2007 01:01 PM

X3 Xmission
 
I noticed the lag when I did my first 2007 test drive back in January '07. Just returned from 4 weeks in Europe after an ED and must say that I did not experience any Xmission lag from day one. It was a great ride. Now the wait for redelivery

Martin5333 07-29-2010 01:27 PM

Guys,
I know this is an old post, if it`s helpful anyhow, I got to let you know that my X3 had the famous jerk on the 1500 - 2000`s rpm (yeah...mine too). I have steptronic in my vehicle. The reset worked beautifully. Jerks gone and soft shifts..
Ciao !

El Zilcho 07-29-2010 04:34 PM

Sounds promising, will try it on my in the evening.

CleanKM 07-29-2010 05:13 PM

Will give this a try tomorrow morning before my commute. I know that modern cars have the ability to reset their learned techniques (my ML320 was able to do this), but this completely escaped my head about doing it to my X3

knight4825 07-29-2010 07:09 PM

I have a 04 x3 2.5, I just tried this and had two questions. Does it work on my car and how do I know if it worked?


All times are GMT -7. The time now is 04:55 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms