Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 M5 (1998-2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=109)
-   -   Monitor, audio system or electrical problem? (http://www.bimmerfest.com/forums/showthread.php?t=205357)

hookedonbmw 05-10-2007 08:01 PM

Monitor, audio system or electrical problem?
 
2000 BMW M5 - Problem occurs for first time in 2007

Monitor goes gray much with random inteference pattern lines much like a TV that is receiving no signal. However audio system (Radio and CD player) continue to work but every 2 minutes and 40 seconds the sound goes completely dead. I need to push the on/off button once to turn power off, and a second time to turn power on. Upon turning on audio system comes backto normal. Screen stays scrambled.

I know the audio system works even though sound goes off, because I can hit the pre-set radio buttons, or buttons to switch CD tracks and when I push the on/off button twice (once to turn power off and once to turn power on) the radio station selection or CD track selection has been done. As I said can resume listening to the Radio or CD normally but in 2 minutes and 40 seconds the sound will go dead again.

All this can be fixed temporarily. I open the trunk unhook one of the battery cables and then re-attach. Upon reattaching the cable and turning the car ignition the monitor appears to get reset and functions normally. Audio system now functions pefectly normally. Everything is fine and then after a few days I see the monitor go gray and scrambly again. I get the audio system problem again too.

I have repeatred this temporary fix several times to verify consistency. I have had never had any problems with the either the audio system or monitor. This problem first occured this past winter. Any ideas on what my first actions for problem diagnosis should be?

DouglasABaker 05-28-2007 07:47 PM

I would guess it is a bad Nav unit, which controls all of the functions of the screen. The sound issue presents an interesting twist though.

In any case, the monitor is exactly that - it has no "smarts" in it at all. It simply presents you with the information the nav system sends it. So your problem with the screen sounds to me like your nav unit has an issue - pulling the plug on the vehicle causes a reboot which could explain why it is temporarily fine.

I suspect the sound issue is related and is caused by a bad command being sent by the nav unit. I would venture to guess that you have a DSP equipped vehicle?

Diagnostic method: Next time you have the screen issue instead of disconnecting the battery you should try unplugging the nav unit instead. If re-booting the nav unit (instead of the entire car) solves your problem, you have found your culprit...

d-

stika 05-29-2007 08:26 PM

+1

bimmernav 06-01-2007 07:11 PM

This issue is a result of your battery being low voltage. A low voltage on your battery although it will start just fine will cause these issues. Look at the magic eye on your battery. I am sure it will be black instead of green.

You can test the battery by following the BMW process of removing the surface charge. 5 minutes with the high beams on and the car off then test the voltage.

Here is the official training docs from BMW AG to BMW dealers explaining this process. Replacing your battery should fix your issue of the radio turning off after 2 minutes.

BMW Battery Training Doc

Martin

mark_m5 06-01-2007 09:34 PM

Interesting. I have not experienced this, but I'm curious to find out what solves it.

Please keep us posted!

f4y 06-25-2007 07:44 PM

same issue
 
Not sure why this is happening... I have a 2000 740 il and the navigation "on"indicator light where it is inserted in the trunk is not on; can't eject to try to update my nav cd, which is a 2003 cd). thought that might have been the issue... replaced my battery in dec 2006, so i'm not sure what's causing it... reply to my thread to let me know if u figure it out first. bmw charged a nice diagnostic fee but the computer read no faults; the shop foreman "did something" (he stated he doesn't know what, it just came back on), so it worked for a few days, but no longer, and now they wanna charge another $100 to check it again

TwoBMWs 06-27-2007 12:02 PM

I have experienced the same exact problem you explained. One day, the nav screen was gray and blank. When I turned the ignition on, the screen turned black with a fuzzy white line across it. The radio or cd will play for 2 minutes and cut off. If I push the radio button back on, it will play again for 2 minutes and cut out again.

I had a dealer look at it, and charged $95 to hear the internal nav system failed and a new computer would be $3000. I took my car to another mechanic for a second opinion. It was there that I learned there had been a navigation system failure campaign (84-06-00) on many of the 2000 models. My model was among them. Questioning Customer Relations and then the dealer's assistant manager, I was told yesterday that the BMW records database said it had been modified with the retrofit adapter cable in March, 2001. As I purchased this certified auto from a BMW dealer in December, 2002, I was unaware of the campaign (recall). Now I question if it was truly retrofitted, and if so why did it fail exactly as explained it would in the recall letter if not corrected? Were the early navigation systems "lemons" or is it something else?

BMW Customer Relations wasn't very helpful. He kept repeating that the car was out of warranty and "things" wear out. I've not heard of a navigation and radio system wearing out -- have you?

TwoBMWs 06-28-2007 12:17 PM

Does my 740il have two batteries. One for electronics and one for ignition. Could it be the electronics battery is very low and is causing the gps & navigation system problems? I have the blank, black screen and the 2 minute radio play. The dealer said the internal computer failed. Is that it?

WOA 11-08-2007 11:23 AM

Me too
 
I am having this exact problem. I changed my battery (not purchased from BMW) and my GPS monitor screen is gray with occasional "interference". The radio works for 2 minutes and then turns off, but I can immediately turn it on again. However, the monitor remains blank. Any ideas??

DouglasABaker 11-13-2007 07:24 PM

Radio is controlled by the tuner and the amplifier (is you have DSP). All screen output is controlled by the Nav unit.

If your screen is gray there are only 3 causes: Bad boardmonitor, interference/fraying of the signal cables, or a bad Nav unit.

If the radio cuts out there are only 4 causes: Bad boardmonitor, intereference / fraying of the power cables, bad tuner, or bad amplifier. If it also cuts out while playing a CD then we can eliminate the tuner (unless you have DSP, in which case we eliminate the amplifier).

The only common thread in these failures (since you've already changed the battery) is the boardmonitor. If, for some reason, it were to send incorrect signals through the iBus and have a screen failure it would explain your issue.

Unfortunately, the only way to diagnose is to put your nav into someone elses car and see if the problem recurs...

d-

H2oskiphil 11-21-2007 12:12 PM

Since I upgraded my OS on my MKIII to v22.1, I'm having the same issue.

Worked fine before the upgrade of the software.

The only thing odd or different about the upgrade was that I got an error message twice when I tried to load the software upgrade.....it took the third time around.

I haven't tried pulling power from the nav system or disconnecting the battery yet to see if it will reset.

Should I try that first?

I'd rather go back to the old software than deal with the constant resetting of the monitor....is that an option? If so, where would I find the software for the older versions of the firmware?

Bugeater 12-05-2007 09:04 AM

Radio turns on and off every 2 minutes? Check
Fuzzy Monitor? Check

Solution ---> replace NAV unit (had the MKII).

I upgraded to MKIII....once the NAV replaced, walaaah. No fuzzy monitor or radio turning off.

gerosean 04-27-2008 09:53 AM

740 monitor screen
 
hi i also have a 97 740il with similar problems but my screen simply is very dull as though a back light has gone you can only see it at night and up close .has any one else had this problem ?

shamus_mcd 05-07-2008 03:25 PM

New to forum / problems
 
I'm not sure if this is related?
I have a E39 M5 and my Stereo/sat nav,tape deck,cd,etc etc keep cutting off so no sound.
I have to got and turn off head unit go to the boot and gigle the wires then go back in to the car and hey presto we have NOISE.
Any ideas i've had the AMP out (NOT DSP i think) and could see any loose connections in the round pin connector block. :dunno:
What do you think?
I've only had the car a couple of weeks.

So Far:-
2x new tyres
front discs
front passenger wheel bearing
drivers door seel
Exhaust CPS replaced
$hi* load of polish too.
Now this :mad:

http://i288.photobucket.com/albums/l...cd/M5front.jpg
http://i288.photobucket.com/albums/l...M5interior.jpg

hookedonbmw 12-14-2008 05:23 PM

To all you folks who replied to my original posting regarding my montior and sound problem: Thank you and especially to those who though it was the Naviation system, as it did turn out to be the problem. My good friends at a BMW shop (not dealership) sensed it was the Nav system and removed to inspect it. It turns out the fan was not working well, not cooling the unit, causing problems which led to the sympoms I described. They swapped in a used Nav unit, and I have not had any problems since. The dealership actually wanted me to replace the monitor/radio unit, which was a complete red herring. .

litoca 04-10-2009 01:32 PM

Bad Nav - Can't I simply disconnect the Nav system?
 
I have a 2001 740IL and am experiencing the same problem: black screen with white lines.

I disconnected and reconnected the Nav system system last night. The problem went away for now. However, based on what I have read here, it is likely to return.

My question what happens if I disconnect the Nav permanently. Does the screen work normally for all other functions? Or will it only function if the Nav is connected?

mcbtex 06-02-2009 02:50 PM

litoca,
how did you disconnect the Nav System? i'd appreciate some hints on how to do this.
i'm having the same problems on my 2001 740il radio/nav system ... screen is fuzzy and radio turns off every 2 minutes 40 seconds.
thanks,
Mark

mcbtex 06-02-2009 02:56 PM

TwoBMWs,
what solution did you come up with for the problem?
i'm having the same problems on my 2001 740il radio/nav system ... screen is fuzzy and radio turns off every 2 minutes 40 seconds.
thanks,
Mark

hafiz1966 01-19-2010 06:14 AM

Monitor goes blank and audio systems (Radio, CD) shutts-off in about a couple of minu
 
I found that the brand new battery (made by Interstate) on my 2001 740iL was a bad one. within a month of putting this battery, I started to have this exact problem and I started to look for replacing my Navigation unit in the trunk as recommended by some in this forum and I was about fork-out $3000 at the local BMW dealer. Then, one morning I found that the battery was so weak that I could not even start my car. I took the battery to the vendor and discovered that it was a bad battery and got a new replacement battery - and all on a sudden, all the problems just vanished - the monitor is back and audio systems are functioning again as they should be. Hope, this experience will help others with similar nasty problem. Please, check your battery first. Just because your car is running, does not mean that the battery has full power. I guess BMW automatically shuts down all non-essential systems to preserve the battery's remaining power to help you drive the car.

Aussie Craig 08-12-2010 06:29 AM

Monitor blank and Indicator has no sound in use.
 
What a fantastic site!I have just saved $1000's by reading your blogs.I had a problem with my Indicator playing up and the Sat Nav Screen with no visuals.The BMW Dealership suggested that it was a Stering Cluster that was going to cost me $1900 plus labour,and the Sat Nav to be replaced costing $2000 odd plus labour.I read what a couple of members said and it worked.I disconected the Battery for a minute and all started working just fine.Cheers for that.:):)

ssnantucket 12-31-2011 11:23 AM

Where is NAV unit located and How to access LCD Screen in Radio tape unit
 
My trusty 2001 X5 (E53 I think) pretty new only 52K miles, has just exhibited this same problem. All of a sudden there is no display on the normally welcoming date and time Nav Screen and the radio with DSP when turned on operates for approximately 2 minutes then there is no sound. Turn it off then on the sound returns. The dealer installed BMW Bluetooth ULF option also continues to work. It seems that the the diag/repair sequence is try removing nav unit cable, try battery disconnect to reboot, try replacing the nav unit. But where exactly is the NAV unit are we talking the the UNIT where the DVD is instaleld in the left rear quarter panel or is it behind the LCD display in the instrument cluster and if so how do you access that there does not seem to be any easy to "get at" the LDC dispaly or radio tape unit? Are there any photos of how to access any of these?

stlmethod 03-01-2012 03:53 PM

I have an e46 3 series with the MKIV nav system. I was having gray screen issues. I initially upgraded the software to V32, which didn't help. I ultimatley replaced the navigation DVD drive. It's a DIY but I paid the dealer $130 parts & $122 labor to do it. So far it works (Been 2 months) but I did have 2 occasions where after hitting a bump where it went back to the gray or flickering screen then rebooted. I'm assuming it may be the cooling fan or battery being bounced around:
http://www.xoutpost.com/electronics/...-nav-unit.html
Also check out:
bimmernav.com
Revtronic.com

J

Teesand 10-16-2013 05:23 PM

bmw screen blinks
 
Quote:

Originally Posted by bimmernav (Post 2417159)
This issue is a result of your battery being low voltage. A low voltage on your battery although it will start just fine will cause these issues. Look at the magic eye on your battery. I am sure it will be black instead of green.

You can test the battery by following the BMW process of removing the surface charge. 5 minutes with the high beams on and the car off then test the voltage.

Here is the official training docs from BMW AG to BMW dealers explaining this process. Replacing your battery should fix your issue of the radio turning off after 2 minutes.

BMW Battery Training Doc

Martin

could this also cause early morning nav screen going on and off? Later in the day, no problem, just early morning for past month. goes away after driving for 20 minutes


All times are GMT -7. The time now is 09:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms