Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   04 745i AMP/radio problem (http://www.bimmerfest.com/forums/showthread.php?t=271827)

adam745 03-21-2008 03:59 PM

04 745i AMP/radio problem
 

Just Purchased my 04 745i as a 1st car.
Having problems with the audio, someone please help..

Radio works sometimes,
when it doesnt work the display views FM/AM etc. however the channels do not show up.
When the radio does work or even when it doesnt the speakers give off a cracking snapping noise, sounds like loose wiring but I checked everything and nothing is lose. I sent the vehicle out to a ''PROFFESIONAL DIAGNOSTIC GUY'' and what he told me is he is not sure what the problem is however he will need to start with a radio, new radio lists for over $850 and then he said I might even need an amp which lists for over $900. plus the programming which will cost me another $3-400. I would appreciate it if one of you BMW techs can help me solve my problem. thanks.:cry:

1bad540 03-21-2008 07:44 PM

have the car professionally diagnosed instead of just guessing and changing parts:(

johndade 03-21-2008 08:18 PM

+1 do it right the first time y waste time with someone that wants to change all the parts and probably doesnt know how to do it proper

BMW_tech 03-21-2008 08:31 PM

Quote:

Originally Posted by adam745 (Post 3109077)
Just Purchased my 04 745i as a 1st car.
Having problems with the audio, someone please help..

Radio works sometimes,
when it doesnt work the display views FM/AM etc. however the channels do not show up.
When the radio does work or even when it doesnt the speakers give off a cracking snapping noise, sounds like loose wiring but I checked everything and nothing is lose. I sent the vehicle out to a ''PROFFESIONAL DIAGNOSTIC GUY'' and what he told me is he is not sure what the problem is however he will need to start with a radio, new radio lists for over $850 and then he said I might even need an amp which lists for over $900. plus the programming which will cost me another $3-400. I would appreciate it if one of you BMW techs can help me solve my problem. thanks.:cry:

Your professional guy should use the GT-1 to perform a MOST-Bus diagnosis to find out what the cause is for the interruption.The test plan would have revealed the probable causes by way of determination.If the test plan reveals 2 or more modules are causing it,he simply could have "jumped" the fiber optics on the modules listed to see if operation resumes and move on to the next "probability".An educated guess is one thing,an educated technician is another.

adam745 03-21-2008 09:47 PM

Thanks guys but this stupid guy feels like hes a king and doesnt explain anything, its as if hes doing me a favor, i will take it to bmw however i was just wondering if anyone experienced or knows about problems like this and maybe can give me ideas of what it can be. thanks.

BMW_tech 03-21-2008 11:29 PM

Do you have any other problems with the sound output ? In saying that I meant, Does the CD Changer operates with sound output ? Does the NAV give you voice instructions ? Does it chime when the key is just on and not running ? Basically,are all your SOUND outputs inoperative ?
We need to determine what works and what doesn't.We can isolate possibilities and eliminate them one by one,thus the need for more information.If you can,borrow a MOST bus "jumper" from another car.This is located in the glovebox,looking in it's on the top panel with a "door".You cant miss it,that's the MOST bus connection for the OPS.(Pin 1 is incoming,2 is out) You can try to "reset" the MOST by turning the key on and disconnecting/reconnecting the jumper plug.The reason why I asked you to "borrow" or "buy" one of these ( 61 13 6 917 541) is so you can use it to bypass the module you suspect to be faulty.You will simply unplug the 2 Pin MOST bus connector from the module and plug in the jumper to see if MOST communications resume.In the left side of the trunk area,behind all the panels you would need to remove.There lies the LOGIC 7,TEL,NAV,and SVS (speech/voice command) modules.
The AVT (Antenna Tuner) is a possibility to your problem.The tuner is actually a control unit with a MOST port and is placed in the rear left C pillar. Due to the direct connection of the antenna diversity,no antenna amplifier is needed on the left-hand side.On the right hand side, there is an antenna amplifier which is linked via a coaxial cable to the diversity unit. The tuner provides the power supply to the antenna diversity and the antenna amplifier.
The ASK (in dash CD-Player) is the MOST network controller.This is the module responsible for PDC acoustics,check control warnings and gongs,and medium-range loudspeakers and tweeters are directly controlled by the ASK.

Brief audio failures

These failures are followed by a magazine check from the CD changer and the sound returns.
1. Stationary or On engine start
The cause is the CD changer or a poor state of charge of the battery.
2. As of terminal 15
The cause is the CD changer.

The stored radio station lists are lost here.
The cause is the antenna tuner.
These audio failures occur in the radio mode, do not occur in other audio sources, and
otherwise the communication systems work normally.
The cause is probably the antenna tuner.

Sustained noise from the loudspeakers

These noises only come from the front door loudspeakers or from the back shelf.
The ASK supplies the front door loudspeakers and the back shelf. Noises from these loudspeaker can also originate from other audio control modules (telephone, navigation system, etc.). Bridging (jumper) these audio control modules can pinpoint the fault.
These noises only come from the central loudspeaker at the front, from the woofers under the seats or from the rear door loudspeakers.
The cause is the amplifier (Top-Hi-fi).
These noises only occur in the radio mode, not with other audio sources.
The cause is the antenna tuner.

adam745 03-22-2008 09:20 AM

All sounds are inop including the park assist, this only happens sometimes , well most of the time.. Have any idea what It might be now? Another thing that may help you eliminate some is only FM AM WB and TONE are highlighted, the CD and CD changer on the screen are faded and only work when my tuner works.it does not chime when inserting the key in. The navigation is giving me a blank screen. When I first purchased it I realized the navi disc was out so while trying to insert it the unit would not take it in, waited a few days and today it took in the cd however I am getting a blank screen when coming to the navi. Please help me before sending it to the dealer, is there any other possible way I can check it . Thanks a lot bmw tech. Apprectiate it.

adam745 03-22-2008 09:24 AM

Also sometimes the roller that controls the audio loosens up and does not respond to my hand movements, and sometimes when first turning on the vehicle on the display screen it shows KOMMUNICATION, Ent. Etc. In different spelling before having to click ACCEPT, after hitting accept everything adjusts but still no sounds. Sometimes and all the time when it does work speakers crack and snap.

BMW_tech 03-22-2008 09:48 AM

E65 Control Module that resets : Control Display Gateway
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen.

E65 Control Module that resets : Control Display
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen

E65 Control Module that resets : CD Changer
What happens to the audio? : Off Briefly
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns.
Other symptoms : CDC shuffles

E65 Control Module that resets : Logic7 Amp
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Antenna Tuner
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : No change or NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Voice Activation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Navigation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV map portion of screen “Initializes” or NAV portion of screen flashes white/gray.

E65 Control Module that resets : Telephone
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Audio System Controller
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Instrument Cluster
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns
Cluster completely dark

adam745 03-22-2008 09:58 AM

So basically I need to change the control module? But some of those symptoms do not match up with what my car is giving off, my screen does not flickler and flash..I'd appreciate it if someone can call me at 1347-322-7616 and make my life a lot easier, thanks bmw tech.

adam745 03-24-2008 07:29 AM

Pics of my 7-Need advice on what I can add to make it look better!
 
Here are some pics of my car, what should I add to make it look better, I am looking for small details like rear window spoiler, & rear lid spoiler, not looking to invest too much $ ,please provide me with some sites where i can get parts . thanks.


















demontrae 03-25-2008 06:27 PM

hello, i am new to this forum but not bmw,however,i have never owned a 7 before. i bought a 02 745i two days ago with 70K miles on it and when i turn on the radio it sounds like all base you can hear the words but very low.i did not but it from a dealer but the previous owner told me it was the amp. so he bought me the amp however when we plugged it in it still sounded the same. are there any suggestions any of you more experienced owners could give me please.thank you

painisluv 09-20-2008 10:52 AM

Audio Snapping and Control Panel Flickering
 
Quote:

Originally Posted by BMW_tech (Post 3110786)
E65 Control Module that resets : Control Display Gateway
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen.

E65 Control Module that resets : Control Display
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen

E65 Control Module that resets : CD Changer
What happens to the audio? : Off Briefly
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns.
Other symptoms : CDC shuffles

E65 Control Module that resets : Logic7 Amp
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Antenna Tuner
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : No change or NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Voice Activation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Navigation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV map portion of screen “Initializes” or NAV portion of screen flashes white/gray.

E65 Control Module that resets : Telephone
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Audio System Controller
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Instrument Cluster
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns
Cluster completely dark

Hi BMWTech...What part is being replace here or is there a reset function that solves these audio issues? I'm having the same problems!!!

painisluv 09-21-2008 06:58 AM

Snapping Noise Nav Flickering
 
Quote:

Originally Posted by adam745 (Post 3109077)
Just Purchased my 04 745i as a 1st car.
Having problems with the audio, someone please help..

Radio works sometimes,
when it doesnt work the display views FM/AM etc. however the channels do not show up.
When the radio does work or even when it doesnt the speakers give off a cracking snapping noise, sounds like loose wiring but I checked everything and nothing is lose. I sent the vehicle out to a ''PROFFESIONAL DIAGNOSTIC GUY'' and what he told me is he is not sure what the problem is however he will need to start with a radio, new radio lists for over $850 and then he said I might even need an amp which lists for over $900. plus the programming which will cost me another $3-400. I would appreciate it if one of you BMW techs can help me solve my problem. thanks.:cry:

Quote:

Originally Posted by BMW_tech (Post 3110786)
E65 Control Module that resets : Control Display Gateway
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen.

E65 Control Module that resets : Control Display
What happens to the audio? : Off Permanent
What you may see in the Control Display? : Completely dark, then restarts to BMW banner then “Accept” screen

E65 Control Module that resets : CD Changer
What happens to the audio? : Off Briefly
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns.
Other symptoms : CDC shuffles

E65 Control Module that resets : Logic7 Amp
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Antenna Tuner
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : No change or NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Voice Activation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Navigation
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV map portion of screen “Initializes” or NAV portion of screen flashes white/gray.

E65 Control Module that resets : Telephone
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Audio System Controller
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns

E65 Control Module that resets : Instrument Cluster
What happens to the audio? : Off Briefly then returns with lower volume
What you may see in the Control Display? : NAV portion of screen flickers/flashes then returns
Cluster completely dark

How was this resolved? Can anyone help me?

painisluv 09-21-2008 09:12 PM

MOST jumper
 
Hey BMW_tech,

Today my battery completely drained so I purchased a new one with hopes that the snapping sound from my speakers would go away. It didn't! Since installing the new battery, I noticed that the control panel display (and radio) would not turn off after I completely removed the key. This is probably what drained my battery! I located the MOST bus in the glove box that you mentioned in an earlier post and I unplugged it. I noticed that only one pin emitted a red light and the other side did not. Is this normal? After a few seconds, the control panel display and radio finally went off so I replugged the MOST bus. Please help....:dunno:

painisluv 09-22-2008 09:49 AM

Please Help!
 
Okay I have narrowed my problem down to the NAV system. I noticed this morning that the DVD Nav in my trunk will not shutdown when the car is off and the key is removed. This also makes my control panel stay on sometimes. I think now that the NAV is not shutting down has caused my last car battery to completely go dead. I removed the 10Amp fuse to the NAV (CDC,on-board display panel) in the trunk and now everything shuts down normally. But...now I can't get any sound from any other function and the radio has no programmed stations and the CD and CDC are greyed out. Tried voice command and it doesn't work either with the fuse removed.

Phatcatofto 10-12-2008 03:37 PM

Quote:

Originally Posted by adam745 (Post 3109077)
Just Purchased my 04 745i as a 1st car.
Having problems with the audio, someone please help..

Radio works sometimes,
when it doesnt work the display views FM/AM etc. however the channels do not show up.
When the radio does work or even when it doesnt the speakers give off a cracking snapping noise, sounds like loose wiring but I checked everything and nothing is lose. I sent the vehicle out to a ''PROFFESIONAL DIAGNOSTIC GUY'' and what he told me is he is not sure what the problem is however he will need to start with a radio, new radio lists for over $850 and then he said I might even need an amp which lists for over $900. plus the programming which will cost me another $3-400. I would appreciate it if one of you BMW techs can help me solve my problem. thanks.:cry:


Im having a similar problem. I have a 2004 745i. I was driving with the music on just yesterday, all of a sudden i heard a beep and and my speakers started giving off a cracking/snapping noise. I tried to turn the radio off by pushing the volume button but it wouldn't turn off. Eventually, i succeeded in turning it off. Once i came to a stop, i switched the car off and took out the key....however, the control display would not turn off. I also noticed that my navigation is not working properly as well....sometimes i get a black screen, and other times the screen blinks. Not sure if anyone can help, but please give me any suggestions that might allieve my situation. Adam745- if u found a solution to your problem, please let me know how u were able to do so. Thanks in advance.

kemosobe77 12-30-2008 12:51 PM

hey guys anyone find a solution to this problem? I have the same thing going on, all audio not workining, even the key chime.

harjothundal 12-30-2008 02:24 PM

man... why doesnt bmw just buy back all these damn cars and call it a loss... it is what it is... sorry for all your troubles fellas...

rockygregs 03-10-2009 04:11 AM

well, Did Anybody find a solution to this, Cos it seems like we are all experiencing the same damn problems with this cars. Can someone pls post a response on this to let us know if they were able to daignose what the real problem was a if they were able to get it fixed. I've had my car for two(2) months without no radio or navigation, So any help would be deeply appreciated.

1bad540 03-10-2009 07:29 AM

Nobody brought the car back to the dealers???

mcfalcons15 03-12-2009 12:11 PM

My amp just went out...again. I had a new one installed by a member here a couple months ago. It worked fine since then but now it makes some low modulating noise, and the bass is all gone. Last time my amp went out, all the Logic 7 settings in the idrive were greyed out and couldn't be adjusted. This time I can still adjust the settings. Could it just need to be programmed by the dealer, or should I get a new amp...again? I don't think it is a coding problem, because it worked for all those months.

Kinda weary of buying an amp from ebay...might not work... and all the ones there say all sales final. Go figure. At least the dealer will give me a 2 year warranty on the amp from them.

7Figurez 03-12-2009 01:34 PM

Damn that sucks bro. You were jamin to hard for the ole Logic 7 to handle. Hope everything works out for you bro. I am in the same boat as you no warranty so it sucks. Still havnt be able to get my transmission fixed yet.

mrlaziman 06-28-2009 11:31 PM

idk if my problems can b fixed by a reset ... i here the chiming for every thing ....the nav lady does not stop the music any more to direct me... only my front pass door speaker works with the music...the parking assist works fine but i turn it off because it is annoying... my CD changer in the dash wont come out or play ... my l7 eq doesn't go up or down i have a DVD/TV thing i put in so i play my Cd's on that and i gives the music some quality to the rear deck right and front pass speakers a

wsashraf 09-30-2009 10:44 PM

2003 745i head unit does not work
 
I own a 2003 745I with 69000 miles on it, the warranty just expired 5 months ago and the head unit on the vehicle does not work (radio,climate control, cd, navagation, car data, etc.) and the mouse is loose. The monitor completly goes blank/blacks out with no sound at all. at times, the head unit works for two days or so and then it shuts down for two to three weeks. All systems will stop working. I called BMW of north America and spoke to a representative and told him about my problem. He told me to take the vehicle to A BMW dealer and have it diagnosed and they would open a claim for it and decide if they will cover anything under warranty. I took the vehicle to BMW of Monrovia (Monrovia , CA) and they first told me i had to replace the head unit which will cost $4200 ( and not sure if that is the problem), then they told me it was the battery because it did not hold a charge. The Dealer frankly did not know what was wrong with the unit (i left my vehicle with them for 7 days). I had the dealer change the battery as suggested and it still does not work. Then they told me to change the head unit. I contacted BMW of north America, they told me they would not cover this probelm even thought the vehcile had 69K and it was out of warranty 5 months. This is very disapointing to me how BMW will not stand behind their product. It is not like Iam asking them to cover the brakes or the window regulator, its a unit which has minimal wear and tear, no one thouces and controls entertainement and navagation. I did not have the funds to change the unit and picked up my vehicle. The day I P/u my vehcile, the head unit worked for approxiamtely one week and again it has been not working for the past two weeks.

Everyone becarful that BMW will not stand behind their product. A 80k (when bought new) car with 69k miles and the head unit does not work. This is the last BMW i will ever buy, because i found out the hard way that their product sucks and they will not stand behind it. If they were not going to help me out, why did they ask me to take my vehicle to the dealer? I asked them that question (BMW of North AMerica) and they refused to answer. They basically said the reason they would not help is becasue my vehicle is not under warranty. I told them if my vehicle was under warranty, i would request their help in this matter. I asked them what was their decesion making process on why they would not help? They refused to answer.

So, Iam suck with a 2003 745i which has 69k miles on it and the head unit does not work properly and the dealer is guessing on what is wrong with it. CAN SOMEONE HELP PLEASE.....or recommned a good tech in southern california. Oh and they charged me $588 for the diagnosis of the vehicle.




Anyone with any suggetions.

Thank you,


WA


All times are GMT -7. The time now is 09:36 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms