Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E36 M3 (1995-1999) (http://www.bimmerfest.com/forums/forumdisplay.php?f=106)
-   -   "Check Coolant Level" Message (http://www.bimmerfest.com/forums/showthread.php?t=281670)

sprky296 04-28-2008 10:06 PM

"Check Coolant Level" Message
 
The past couple of days, every time I start up or turn off my car (a '98 M3 sedan w/ 93k miles on it), I get this "Check Coolant Level" message on the OBC. I check the coolant when the car is cold in the mornings, and it's still above the "cold/kalt" line in the reservoir tank next to the radiator. Even when the car was low on coolant, I added enough, yet still get this message. Also, the car seems to be running a bit hot (the temp. gauge is about 2/3 - 3/4 of the way to HOT, but never has reached the red...yet).

I'm not sure if this is related, but I know I need to replace the A/C condenser, dryer/receiver, and fan clutch.

Any ideas as to what may be causing this? Could it be a malfunctioning thermostat, or is there a sensor in the coolant reservoir that could be bad? Could this be related to my s**tty/non-existant A/C? Thanks in advance guys!

Bruce 04-29-2008 06:25 AM

Yes the coolant level switch could be bad. You could be losing coolant from the thermostat housing but not be able to see it (BTDT) especially if you have a plastic (read stock) thermostat housing. If your temp is going up above the middle I would be concerned and get it fixed sooner rather than later. Could be easy as fixing the air flow to the radiator.

e30e 04-29-2008 01:17 PM

If you have no records of cooling maintanence or have not done it in awhile, Bite the bullet now before summer hits and do it too. These cars really don't lie to you about running hot, could be switch or it could really be hot.

sprky296 04-30-2008 08:37 PM

I just got my car back today, and here is the (hopefully) final word of what was wrong with it. The water pump was leaking, the thermostat was "bad" (the mechanic didn't go into any more detail for me), and the upper and lower radiator hoses were on the verge of cracking. Taking the advice I got on here, I "bit the bullet" and had all the work done before summer hits full swing and I get REALLY screwed.

Also, I went ahead and got the aluminum thermostat housing as a preventative measure.

Thanks for all your advice! This forum never seems to let me down.

fun2drive 05-03-2008 01:05 PM

You were smart to get those items replaced and also a lot of times the coolant low sensor gets some gunk on it and cleaning it will allow it to function 50% of the time and other times it is just dead...

sprky296 05-03-2008 03:20 PM

Quote:

Originally Posted by fun2drive (Post 3225360)
You were smart to get those items replaced and also a lot of times the coolant low sensor gets some gunk on it and cleaning it will allow it to function 50% of the time and other times it is just dead...

Stupid question coming here, but I am pretty inexperienced at car repairs. Where is the coolant low sensor, and how can I go about cleaning it?


All times are GMT -7. The time now is 10:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms