Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   Drive control malfunction / drive moderately - steering angle sensor error - SZL (http://www.bimmerfest.com/forums/showthread.php?t=429135)

Keif 01-27-2010 06:55 AM

Drive control malfunction / drive moderately - steering angle sensor error - SZL
 
3 Attachment(s)
As we all know, on our E65/E66's the steering angle sensor will occasionally freak out and throw an error, with the supporting evidence being a non-self-canceling turn signal. After a little while (typically car stop/start) it will go back to acting normal.

Well, mine finally freaked out again this morning and I was able to pull the error. You'll notice that it only happened once, and that it was just for a split second.

I'm not soliciting advice on this, just providing a little information back to the community. Attached are some screen shots from pulling the error using INPA.
 

gman750 01-27-2010 07:09 AM

could you maybe explain what some of the info means on those screens for the folks like me who have no clue what that is?

Keif 01-27-2010 03:36 PM

Sorry...
  1. The first picture is how to get to the SZL / "Satellite steering column" module from within INPA.
  2. The second picture is just a bunch of crap you'd expect to see when you look under identification for this module.
  3. The third picture has the actual error that I got, and some other stuff.
    • "ECU: SZL" ...SZL is the actual module name
    • There is a line specifying both the error number and description, "94E7 / Steering angle sensor: Relative wiper angle faulty".
    • "Error counter: 1" just says that the issue happened once in this instance.
    • "Error present now and already stored" just means that it still thinks the error is there (I didn't turn off the car before pulling this stuff). Once the car was shut off and turned back on, the module rechecked the sensor and determined that all was okay again (after this it said that the error was no longer present, but was already stored).

kwang0429 02-07-2010 01:08 PM

I got the same problem today, but the good thing is, turn off the engine went for a pick up, came back and restart, it's now gone just like how u described it. thanks!

haz1 02-07-2010 04:39 PM

Quote:

Originally Posted by Keif (Post 4885292)
Sorry...
  1. The first picture is how to get to the SZL / "Satellite steering column" module from within INPA.
  2. The second picture is just a bunch of crap you'd expect to see when you look under identification for this module.
  3. The third picture has the actual error that I got, and some other stuff.
    • "ECU: SZL" ...SZL is the actual module name
    • There is a line specifying both the error number and description, "94E7 / Steering angle sensor: Relative wiper angle faulty".
    • "Error counter: 1" just says that the issue happened once in this instance.
    • "Error present now and already stored" just means that it still thinks the error is there (I didn't turn off the car before pulling this stuff). Once the car was shut off and turned back on, the module rechecked the sensor and determined that all was okay again (after this it said that the error was no longer present, but was already stored).

+1, Keif it looks like the counter tells how many times the error happened, but does the machine tell operators what date it happened and time? Or does the error have to occur while hooked up to the machine when in the shop?

Keif 02-07-2010 07:59 PM

In INPA by default it just shows the mileage (in KM) when it happened. I haven't checked using any of the other tools yet (DIS, etc.).

haz1 02-07-2010 09:24 PM

Right on.

italiano 10-20-2011 09:02 AM

Does anyone know how to fix the problem? It goes away after a restart but annoying.

MOPAULY 10-20-2011 01:33 PM

Quote:

Originally Posted by italiano (Post 6391268)
Does anyone know how to fix the problem? It goes away after a restart but annoying.

Lol yes you need to replace the sensor. I had the same issue taken care of under warranty. Mine would only trip after turning the wheels close to or full lock, such as backing out of my driveway.

quarterto8 10-20-2011 05:40 PM

Lmao at gman750 reply! Bro I've known keif for a long time now and when he starts talking bmw he goes into a zone and pretty much no one really knows what he is saying!

los2much 01-19-2012 08:54 PM

same problem how to replace it ?

wjjklj 01-20-2012 08:04 AM

Quote:

Originally Posted by Keif (Post 4883700)
As we all know, on our E65/E66's the steering angle sensor will occasionally freak out and throw an error, with the supporting evidence being a non-self-canceling turn signal. After a little while (typically car stop/start) it will go back to acting normal.

Well, mine finally freaked out again this morning and I was able to pull the error. You'll notice that it only happened once, and that it was just for a split second.

I'm not soliciting advice on this, just providing a little information back to the community. Attached are some screen shots from pulling the error using INPA.
*

Keif,

The third screenshot says on the last line that this would not cause a warning light to come on.

Every time I have had this happen (maybe 3 times in 3 years) I have received a warning light saying to drive moderately. Why does INPA say it will not show a warning light?

USALEXUSBMW750 01-20-2012 09:33 AM

I have this twice, once a year, when i put on my winter tires, but not happened this year thanx God

Keif 01-20-2012 11:07 PM

Quote:

Originally Posted by wjjklj (Post 6575174)
Keif,

The third screenshot says on the last line that this would not cause a warning light to come on.

Every time I have had this happen (maybe 3 times in 3 years) I have received a warning light saying to drive moderately. Why does INPA say it will not show a warning light?

Good question... The best I can figure is that the steering angle sensor itself doesn't cause a warning, but the failed state of the ARS/DSC system does.

Sent from my ADR6425LVW using Bimmer

Nikki1169 01-21-2012 09:57 AM

catalytic converter
 
my catalytic converter is stopped up on my bmw 745 li. any suggestions:yikes:

AceFX 01-22-2012 08:10 PM

Have you checked the ZGM (gateway module) :dunno:


As far as the Cat goes.....:dunno: can they be cleaned? They sure are expensive to buy.....

Nikki1169 01-22-2012 09:31 PM

What is that?

AceFX 01-22-2012 09:57 PM

What is what?

vernon3rdw 10-29-2012 03:01 PM

Do u have any idea how much without the warranty it costs

Sent from my SAMSUNG-SGH-I727 using Bimmer App

seannypoo 11-18-2012 07:35 AM

i have this problem as well, and i cannot reactive my DTC


All times are GMT -7. The time now is 01:56 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms