Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E60 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=104)
-   -   HELP:Transm. malfunction: 2006 530I, 28000 mi. (http://www.bimmerfest.com/forums/showthread.php?t=505746)

mperez 12-14-2010 01:10 PM

HELP:Transm. malfunction: 2006 530I, 28000 mi.
 
I finally read all the message! Transm. malfuncion: Functionality or display of gear selector position may malfunction. It may be possible to engage a gear without depressing brake pedal.

Also when I start my car, on the display console a picture pops up it looks like a gear w/exclamation mark in the middle and there is also a picture that looks like a motor?

I have ordered the service manual, so I can't look it up yet.

My question now is, I can't take it in till fri. So if anyone has seen this problem is it safe to drive? Does anyone know how bad this situation is? :dunno:

klrichard 01-29-2013 10:11 AM

What was the final outcome?

v8power 01-29-2013 10:25 AM

I had this before and dealer just replace a new shifter/gear selector. Quite a common problem on 2008 lci's.not sure on other models

klrichard 01-29-2013 10:39 AM

Cost?

v8power 01-29-2013 10:47 AM

This was still while I was under warranty but I believe the shifter cost was $2xx.00 plus an hour labor. It is a diy'able job as its just r&r and clear code

But yours is a pre lci so check before replace.

klrichard 01-29-2013 11:07 AM

Thanx!


All times are GMT -7. The time now is 07:00 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms