Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E36 /7 Z3 (1996-2002) (http://www.bimmerfest.com/forums/forumdisplay.php?f=7)
-   -   Z3 Trouble signs? (http://www.bimmerfest.com/forums/showthread.php?t=509953)

Eighthnote 01-03-2011 01:25 PM

Z3 Trouble signs?
 
Hello all, I noticed some "steam" rising up from under the hood today. :cry: No gauge indication of running hot. :) Open up the hood and could smell coolant but no leaks. Then I saw it. My fan is not parallel to my radiator. Looking at the fan from the front of the car the left side of the fan is much closer to the radiator than the right side. Also when I pull slightly left to right I see the fan pulley moving. Could the bolts just be loose or do I have bigger issues? Thank you all in advance.

Update: I don't think it's as simple as the bolts being loose.

SUNZOUT 01-03-2011 03:16 PM

Your water pump has gone.. do not start or drive the car....

You will damage way more than the waterpump

reidconti 01-03-2011 03:35 PM

Your pulley bolts COULD be loose. Are they? Should take all of 10 seconds to check. If they're not, your WP is blown. SUNZOUT is right, don't drive it.

Eighthnote 01-03-2011 04:34 PM

Thanks folks. It's tucked away in the garage. Time to get my Bentley Service Manual out and see what's involved.


All times are GMT -7. The time now is 07:59 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms