Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X3 E83 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=65)
-   -   Headlight wash inop?? (http://www.bimmerfest.com/forums/showthread.php?t=523067)

xbdrabbitx 02-27-2011 03:55 PM

Headlight wash inop??
 
05 x3. Headlights on and I think in heard the pump activate when i ask for wash on the third time, but receive no fluid expelled. I don't see any leaks from here the fluid is. Any ideas?

xbdrabbitx 02-27-2011 03:57 PM

Also just bought the car and this is the first time i wanted to see it work.

AzNMpower32 02-27-2011 08:18 PM

The headlight washer sprays the first time the windshield is washed when the headlamps are on, and every 5th time after that.

If you are hearing the pump activate but nothing is spraying, check the hose connection next to the washer fluid tank for any clogs or leaks. If all is okay, likely your pump has gone bad and needs to be replaced (this was my case last year). The part is around $60-70 and easy to do yourself.

CmfortblyNumb 02-28-2011 08:11 AM

I had the same problem after I got my 2006 X3. I could hear a pump, but the headlight washer wouldn't pop up. I mentioned it to the dealer while getting an oil change, and they replaced the pump (under warranty) and everything's been working fine ever since.


All times are GMT -7. The time now is 06:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms