Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E63 / E64 6 Series (2003 - 2013) (http://www.bimmerfest.com/forums/forumdisplay.php?f=114)
-   -   05' 645ci convertible Logic 7 Amplifier Replacement (http://www.bimmerfest.com/forums/showthread.php?t=535404)

ragal 04-18-2011 08:31 AM

05' 645ci convertible Logic 7 Amplifier Replacement
 
Hello

i come from Germany-Berlin

I got a 645ci and my sub from left, rear side are sound like he blowing up

its the amp 100% but now i tryed to open the plastic trunk cover but there's one problem:

I removed all screws etc,,, but theres 1 fiber cable that hold the cover?

how i remove him??, and

DOES Somebody have a nice guide how to replace amp????? this would be nice!!!!

gretting's from hauptstadt berlin

ragal 04-18-2011 06:24 PM

Please could someone help me!!

I used the search function but only found 1 thread and there's no guide how to replace :/

Yorgi 04-18-2011 06:42 PM

Here are the TIS instructions: Online TIS Logic 7 Amp Removal

I'll go take a few screenshots of the missing first 2 steps. I'll need to get those from my local copy of the TIS.

Here is a step by step set of instructions, no pictures but it explains that you need to unplug the fibre optic cable. coug60's Logic 7 amp install DIY

tampamark 04-18-2011 07:49 PM

2 Attachment(s)
Quote:

Originally Posted by ragal (Post 6004133)
Hello

I removed all screws etc,,, but theres 1 fiber cable that hold the cover?

how i remove him??

Seems like you may be stumped pulling off the cover. If I read this right, it is a metal cable and is nothing more than a ball end, release it by pulling the metal wire sideways out of the channel. The little ball comes out last. When you put it back in make sure and snap the little ball back into the clip all the way. Just take a look at the picture to see what it looks like with the clip removed.

Make sure you reattach all the way, this has something to do with the convertible top if memory serves me correctly.

EDIT: On a side note, the TIS program also has a special warning you should be aware of. When removing and installing the Wheel Arch Cover take extra care and confirm that the convertible drain hose is still attached. It is easy to knock it off and then you will have water ruin your electronics in the trunk.

Yorgi 04-18-2011 11:54 PM

3 Attachment(s)
Here are a few more TIS instruction pages. First 2 on how to remove trim and last is how to remove the amp.

ragal 04-19-2011 05:07 AM

Hello,,


Omg, Thanks to all who help me!!, it helped me allot!

This is the best helpful forum in the world for Beamers;)

Thanks again...


EDIT:

Now i removed the whole cover (trim or w/e) , And Removed 5 Screws

But the Amp Dont move a bit!!!

Now i Explore , Behind the Amp are 2 screws more

But how the hell i get the screws removed?? my fingers are fat and even with the pincers i cant get it drilled

Here i tryed to show u what screws i removed:

http://i55.tinypic.com/2zylpft.jpg

I'm now @home

I will make later a Photo with my M-O-B-I-L-E P-HoNE


Sry for my bad english =)

tampamark 04-19-2011 10:04 AM

hmmm, I have never gone so far as to have to pull the amp out. I had removed the back carpet and arch for another issue so I am no help there. There must be something you are missing, perhaps you do not need to remove those behind the amp? The TIS shows some releases in the front.

Good luck.

ragal 04-19-2011 03:43 PM

:):):):)

NVM


I Fixxed the problem was i dont removed the plates under the amp

:thumbup::thumbup:

Now the amp is removed and i try to fix this by a local hifi dealer

;)

Thanks to all!


All times are GMT -7. The time now is 01:38 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms