Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E89 Z4 (2009 - current) (http://www.bimmerfest.com/forums/forumdisplay.php?f=145)
-   -   2011 Z4 Fuel Pump Noise (http://www.bimmerfest.com/forums/showthread.php?t=546891)

Atlas350XL 06-07-2011 09:07 AM

2011 Z4 Fuel Pump Noise
 
Two to three weeks after I took delivery of our 2011 30i Z4 it started to make a high pitched howling noise. It has continued to get louder as the weeks go by . . . it can now be heard while standing several feet away from the car. The dealer said that has been an issue with the 2011 Z4's and there is nothing they can do about it. They have tried changing the fuel pump in other 2011 Z4's and it is quiet for a couple of weeks and then the noise returns.

I called BMW N.A. and they do not have a fix for it at this time. Has anyone else had this issue?

Love the car except for this constant noise . . . which I can now hear over the radio.

SANguru 06-07-2011 11:58 AM

Quote:

Originally Posted by Atlas350XL (Post 6115938)
Two to three weeks after I took delivery of our 2011 30i Z4 it started to make a high pitched howling noise. It has continued to get louder as the weeks go by . . . it can now be heard while standing several feet away from the car. The dealer said that has been an issue with the 2011 Z4's and there is nothing they can do about it. They have tried changing the fuel pump in other 2011 Z4's and it is quiet for a couple of weeks and then the noise returns.

I called BMW N.A. and they do not have a fix for it at this time. Has anyone else had this issue?

Love the car except for this constant noise . . . which I can now hear over the radio.

bring it to another dealer! East Bay is a lot better than Fremont. Nothing they can do? that's BS. Have them open a PUMA case ASAP.

Atlas350XL 06-07-2011 05:02 PM

Took it to BMW Concord. I already know about BMW of Fremont . . . I would not take anything to them. Thanks for the suggestion . . . I may try East Bay BMW.

Did you have the same noise problem with yours?

Atlas350XL 06-07-2011 05:04 PM

What is the PUMA?

SANguru 06-07-2011 05:15 PM

no. I am not picking up my Z4 until July. Don't bother with Concord either. Go to East Bay. a PUMA is a problem case that gets logged into a database with BMW when something has not been able to be fixed. BMW Regional Techs get involved and it gets funneled back up to BMW.

Atlas350XL 06-07-2011 06:07 PM

Oh! OK . . . well that makes sense then. I have been reading about a HP Fuel Pump recall that happened last Dec. Similar problem . . . I believe BMW needs to get fuel pumps from another vendor . . .

I am not going to let this go as I like the car and want it to be the same way it was when I drove it off the dealer's lot in Feb. Thanks again for your comments and feedback. Much appreciated.

baconway 06-07-2011 08:49 PM

My 2011 Z4 30i has the same problem. It was ordered in Jan and delivered March 30.

As with yours, it did not make the noise for a few weeks.

I've noticed that with mine once the gas tank gets below 1/2 full the noise disappears.

It is really irritating and I've asked the service dept. about it. They told me a BMW rep needs to visit and approve the repair.

Atlas350XL 06-08-2011 08:16 AM

Interesting that the noise goes away after the fuel drops below 1/2 tank. Mine still makes the noise below 1/2 tank of fuel. BMW obviously has a problem with High Pressure Fuel Pumps. Make a formal complaint about it to the number I posted in a previous post above . . . the more complaints they get will help prompt BMW to come up with a fix for this.

baconway 06-08-2011 08:39 AM

I could be mistaken but I don't think our Z4 30i's have HPFP's. I think those are exclusive to the cars with turbochargers.

BMW certainly does have problems making HPFP's-but it seems they also have problems making plain old electric fuel pumps.

Atlas350XL 06-08-2011 09:41 AM

Yes I believe you are correct, those are for the turbo's. I've been reading too many posts about the HPFP's. Sure wish they'd come up with a fix for the 30i's as I love the car except for that incessant noise...

Atlas350XL 06-23-2011 09:05 PM

SANguru . . .

Got a call from BMW of North America last Wed. As per their suggestion I took it to East Bay BMW on Thursday morning for a second opinion. East Bay BMW said they thought it was the fuel pump and want to put it on a lift to look at that area of the under carriage. They asked if I could leave it till later in the afternoon . . . and they gave me a loaner car for the day. They changed the fuel pump and VOLIA! NO more fuel pump noise . . . . I hope it stays that way.

SANguru . . . thanks for your suggestion to take it to Easy Bay BMW . . . good dealership! Think I may switch to them for my service needs from now on...

baconway 07-10-2011 07:34 PM

I had the fuel pump replaced two weeks ago. Now after only 200 mi the humming sound is returning. It's really disappointing.

Has anyone had better luck?

Atlas350XL 07-11-2011 08:14 AM

Sorry to hear your noise is back on the new pump, something neither of us wanted to see happen. Had mine replaced 337 miles ago and it is still OK . . . "knock on wood". We'll keep everyone posted as the miles roll by . . .

BEAMN 11-27-2012 04:48 AM

I am now just staritng to have this problem with 5K miles on my 2011. Curious if the noise has returned since the pump was replaced.

This car is a dream to drive and love to shift but hate the noise. Hope to get the pump replaced soon.

Regards,

Atlas350XL 11-27-2012 08:07 AM

Yes, the noise is still gone and now have 17K miles on the Z-4 after the fuel pump was replaced.

Atlas350XL 11-27-2012 08:14 AM

New Problem Happened . . .
 
About 700 miles ago . . . around 16K total miles . . . one or two lifters must have bled down because the lifters were making lots of noise . . . took it to BMW and the replaced all the lifters. Noise gone but the car just doesn't seem to have the get-up-and-go it used to have with the new lifters. Sad . . . I am starting not to enjoy the car as much as I once did . . .

RoadstergalZ4 11-27-2012 02:48 PM

The whining that you hear is from the LPFP. I had the same problem and my dealer replaced mine about six months into ownership. It was a high pitched whining sound that seem to be coming from behind my seat. Anyway after the dealer replaced the pump two years ago, I have never had a problem with it.

I have a 35i which has the HPFP. I never experienced any problems with that, but my dealer replaced it anyway as it was a recall. The people that had problems with that had the car going into a limp mode, there wasn't any sound coming from that. The whining sound is from the LPFP. I would take it to another dealer as your dealer apparently doesn't have a clue.


All times are GMT -7. The time now is 08:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms