Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E85 / E86 Z4 (2003-2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=186)
-   -   2004 Z4 EML & Check Engine light (http://www.bimmerfest.com/forums/showthread.php?t=551760)

vj101 06-29-2011 06:33 PM

2004 Z4 EML & Check Engine light
 
This problem came on my z4 lately. I was due on service and i did not do it on time. I passed 15k mile service and got the service done after 19k miles.

Now in between the EML light and Check engine ligts stay longer then they shld. I saw it on other Z4 of similar years and observer it on mine as well. when u turn the key all the lights on the dash turn amber and then they turn off. this should be the normal behaviour on dash.

Now the EML and Check engine lights stay till i start the bimmer and go off after one or 2 sec in Engine start state.

Can anyone point out what's wrong. i want the EML and check engine light to turn off like other lits when i turn on the ignition.

ckojak 10-04-2012 01:24 AM

Hi There!
did you ever find the solution to that issue??

I'm facing the same thing, and it's really killing me to know the reason.

Thanks

Drexel5 10-04-2012 01:01 PM

Likewise - I never thought that this was an issue until seeing this thread. Would be interested in knowing if I need to be concerned.

Mikey48 10-05-2012 07:44 AM

I would worry about these lights if they stayed on. If they are going out after you start your car do not worry about them. Good day.

ckojak 10-05-2012 07:59 AM

i really do hope so,,,
just bothered why they started doing tat out of the sudden...

thanks


All times are GMT -7. The time now is 01:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms