Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   It is a weird thing! (http://www.bimmerfest.com/forums/showthread.php?t=553407)

ioang26 07-07-2011 05:46 PM

It is a weird thing!
 
I am fairly new to the forum and have just purchased 2001 X5 4.4i with 87K miles.
and drove it for a few days and suddenly the SELF LEVELING SUSPENSION INACT. showed up on the screen.
I turned the engine off and then on and disappeared for a couple of days.
Then I noticed it would come on again when the vehicle is parked on a little hill or not leveled ground.Now comes on more often .
I checked the fuses,the air springs make no noise of air coming out.
Also, checked the height of the rear .The ride is good .Everything checks out good.

What could be happening?
Any sensor of the self leveling suspension going bad?

I would greatly appreciate any info and help !

ioang26 07-14-2011 11:55 AM

Just an update .Disconnected the battery for about an hour,then reconnected and so far no "SELF LEVELING SUSPENSION INACTIVE" message.

Zulu95 07-14-2011 12:52 PM

Before you might start throwing money at that system (and it will take buckets at a time) try reading this post if you have not already done so:

http://www.bimmerfest.com/forums/sho...d.php?t=554806

Every forum I go on where air suspension units are on the vehicles always seem to end with problems. Besides the BMW system I see the Toyota 4Runner owners have problems as do Ford Explorer owners. I know the Toyota owners are now pulling the air ride and fitting regular spring/shocks to eliminate the problems.


All times are GMT -7. The time now is 01:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms