Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E46 M3 (2001-2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=107)
-   -   SMG Problem (http://www.bimmerfest.com/forums/showthread.php?t=559344)

BlackStarMiG 08-04-2011 12:49 AM

SMG Problem
 
Ok guys, I'm new to the forum and ive owned this 2003 e46 M3 for about six months and I've had this problem with the transmission. For some reason the SMG takes too long to shift, for example say I'm driving from a stop and its about to shift into the next gear it go's limp for a second then it drops the gear and you keep driving. almost like really bad granny shifting, it doesn't always happen though. wen i go faster or i shift the SMG it works fine the higher gears work fine only in the lower gears. Also is it normal if wen i set it in auto mode it doesn't go down to 1st gear on a stop it go's down to 2nd? please help me out idk what wrong with my car makes me unhappy with it :(

Pinecone 08-04-2011 09:51 AM

You do know there are 6 levels of S mode and 5 levels of A mode to choose from?

The lower levels shift slower. Also the transmission shifts slower when you are off the throttle or at low throttle versus at full throttle.

And A1 does not use 1st at all.

You change the level with the rocker switch with the bars (like the ATT commercial) by the shifter. There is a similar display on the dash that shows which level is selected.

And BTW, RTFM.

mustaine 08-04-2011 12:23 PM

Quote:

Originally Posted by BlackStarMiG (Post 6232859)
Ok guys, I'm new to the forum and ive owned this 2003 e46 M3 for about six months and I've had this problem with the transmission. For some reason the SMG takes too long to shift, for example say I'm driving from a stop and its about to shift into the next gear it go's limp for a second then it drops the gear and you keep driving. almost like really bad granny shifting, it doesn't always happen though. wen i go faster or i shift the SMG it works fine the higher gears work fine only in the lower gears. Also is it normal if wen i set it in auto mode it doesn't go down to 1st gear on a stop it go's down to 2nd? please help me out idk what wrong with my car makes me unhappy with it :(

Sounds like gear position sensor or clutch position sensor issue. Does it blink in low gears before engaging?
Also, it's possible it may require a software update and/ or calibration of clutches.

BlackStarMiG 08-04-2011 02:40 PM

thanks guys for the reply, well thats what i thought about the A1 that it started in 2nd gear i just wasnt sure. but yea it doesnt flash the gear in the dash before it engages it just goes limp like when it is about to shift no matter how far you push in the gas but as soon as it engages it will throw u back if the gas is in a lil deep usually happens when i'm going to turn left wen I'm in the intersection :dunno: whats wrong with it

BlackStarMiG 08-04-2011 02:43 PM

also how do you update the software or calibrate the clutches is that something i have to take to the dealership?

mustaine 08-04-2011 02:57 PM

Quote:

Originally Posted by BlackStarMiG (Post 6234164)
also how do you update the software or calibrate the clutches is that something i have to take to the dealership?

Software Update - Dealership
Clutches - Good Indy can do it provided they have worked on it previously.

I'll first look into gear position sensor and then move to other things.

mustaine 08-04-2011 03:09 PM

If you want to go Indy route in your area, Bimrs.org recommends:

Bavarian Motors LTD
Contact Name: Andrew Sanchez
Phone: 602-254-7380
2417 N 16th St
Phoenix
Arizona
85006

http://www.bavarianmotorsltd.com/

Disclaimer: I'm do not represent them or associated with them. :rofl:

BlackStarMiG 08-05-2011 01:08 AM

thanks man you have been a lot of help i really appreciate it :thumbup:


All times are GMT -7. The time now is 05:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms