Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X3 E83 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=65)
-   -   Front Wipers Don't Pull Up/Away (http://www.bimmerfest.com/forums/showthread.php?t=578991)

djnadina 11-02-2011 11:45 PM

Front Wipers Don't Pull Up/Away
 
My 2 front wipers do not pull up/away from windshield completely as they do on my other cars. The wiping action is fine. However, in the wintertime, sometimes I pull them away from the windshield so they don't stick to the windows due to cold/ice, etc.

Is this normal for the X3?

x3oiler 11-03-2011 12:41 AM

Sure is. Unless of course you want to damage the front hood paint work.
Yes a pain but something that can be lived with. Plastic under the blades for ice conditions for example.

madurodave 11-03-2011 07:02 AM

Easy work around: cycle wipers so they are straight up. Turn off ignition at high point for wipers. Now you can safely lift off for changes and winter/freezing conditions.

Just don't forget to PUT BACK down to windshield surface before turning on ignition or you will damage something.

AzNMpower32 11-03-2011 01:29 PM

You just activate the wipers but turn off the ignition while they are still high up in the cycle, then you can lift them.

djnadina 11-06-2011 09:29 PM

Thanks for the suggestions.
I just wanted to make sure that something wasn't wrong.
It all makes sense!


All times are GMT -7. The time now is 12:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms