Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   Only one speaker works (http://www.bimmerfest.com/forums/showthread.php?t=626959)

Rossidee 06-13-2012 02:21 PM

Only one speaker works
 
HElp needed please

I have x5 2004 3.0 petrol the stereo only plays through the left rear speaker???? Please would like all the advice you got ....

tmvE39/E53/Z32 06-13-2012 02:45 PM

Loose speaker wires? Did you check the Fade and Balance adjusting of the Head Unit?

maurice Esterki 06-21-2012 03:19 PM

Hi

I had this problem 3 years ago. I took it to the main dealer and they replaced either the amplifier or a some sort of signal unit that works in conjunction with the amplifier. It was about 450. Sorry to be the bearer of bad news.

Bullylad 06-30-2012 04:26 AM

Hi,

I had only my front right speaker working and got it fixed this week.

Removed the BM54 amp in the rear of the car and sent it to www.vmkautolocksmith.co.uk

They repaired the amp and sent it back within 2 days working properly and with a warranty.

It cost me 95 inc postage and it works fine.

Hope this helps?

taha_341 08-13-2013 08:52 AM

Only one speaker works
 
hi
ihave problem with the Balance adjusting memory once you adjust it but is not save when you restart the car
I have e39 1997




Sent from BimmerApp mobile app

thegadgetman0 08-16-2013 03:28 PM

Had the same problem last week.
Sent it to Carphonics, got it back the next day fully working. 100

taha_341 08-16-2013 04:14 PM

Only one speaker works
 
Do you know what is the problem exactly


Sent from BimmerApp mobile app


All times are GMT -7. The time now is 04:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms