Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   Classic Bimmers (http://www.bimmerfest.com/forums/forumdisplay.php?f=111)
-   -   HELP! -Check Engine Light (http://www.bimmerfest.com/forums/showthread.php?t=627986)

kbutler1091 06-18-2012 06:40 PM

HELP! -Check Engine Light
 
Hi, I have a 1989 325i. Its in excellent condition with little to no damage with 70,000 miles. Last week, I accidentally left my light on and my battery was dead. In attempt to help me my brother tried to jump the battery. But failed terribly by accidentally putting the positive on the negative, and negative wire on the positive. There were sparks but we quickly realized our mistake and corrected it. Everything seems fine now except my stereo won't work and my check light continuously flashes, and a red light over the check engine stays on. Everything seems fine so does anyone know what maybe wrong?

kyfdx 06-19-2012 08:12 AM

Quote:

Originally Posted by kbutler1091 (Post 6903055)
Hi, I have a 1989 325i. Its in excellent condition with little to no damage with 70,000 miles. Last week, I accidentally left my light on and my battery was dead. In attempt to help me my brother tried to jump the battery. But failed terribly by accidentally putting the positive on the negative, and negative wire on the positive. There were sparks but we quickly realized our mistake and corrected it. Everything seems fine now except my stereo won't work and my check light continuously flashes, and a red light over the check engine stays on. Everything seems fine so does anyone know what maybe wrong?

Much better chance of a response if you post in the 3-series section under E30...

ProRail 06-20-2012 07:31 PM

Quote:

Originally Posted by kbutler1091 (Post 6903055)
Hi, I have a 1989 325i. Its in excellent condition with little to no damage with 70,000 miles. Last week, I accidentally left my light on and my battery was dead. In attempt to help me my brother tried to jump the battery. But failed terribly by accidentally putting the positive on the negative, and negative wire on the positive. There were sparks but we quickly realized our mistake and corrected it. Everything seems fine now except my stereo won't work and my check light continuously flashes, and a red light over the check engine stays on. Everything seems fine so does anyone know what maybe wrong?

I think you explained it pretty well.


All times are GMT -7. The time now is 10:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms