Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E46 M3 (2001-2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=107)
-   -   Washer fluid problems (http://www.bimmerfest.com/forums/showthread.php?t=633712)

vminghelli 07-17-2012 04:46 PM

Washer fluid problems
 
Anyone ever have their washer fluid just stop working? I checked the fluid level it's all topped off but still no fluid flows when pull to wash. Checked the fuses and they look good. Am I overlooking something?

Pinecone 07-18-2012 03:41 AM

Quote:

Originally Posted by vminghelli (Post 6957334)
Anyone ever have their washer fluid just stop working?

Nope, the fluid always seems to work, if it gets to the windshield. :)

Have someone activate them while listening near the resevoir. Does the pump run?

If so, check the hoses.

If not, check the voltage at the pump.

No voltage, check the wiring and switches.

Voltage there, replace the pump.

skuzlm3 07-25-2012 08:05 PM

99% pump.

Pinecone 07-26-2012 01:23 PM

Agreed, but do the checks first. Nothing like buying pump, and when installing, find out the connect becamse disconnected, or a hose chafed through.

vminghelli 08-02-2012 09:28 PM

I will check it out, I am in the middle of a move, so havent had a whole lot of time to check it out. Texas the only state where you can move 10 hours away and still be in the same state. I was reading other post on here and realized I have alot to learn about BMW, I have been paying 90 bucks for a oil change every 3000 miles. I have had Mustangs and a IROC, but cant make me smile like my M3.


All times are GMT -7. The time now is 02:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms