Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E85 / E86 Z4 (2003-2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=186)
-   -   Z4 Z4 top does not go up all of the way (http://www.bimmerfest.com/forums/showthread.php?t=633926)

RClonch 07-18-2012 01:34 PM

Z4 top does not go up all of the way
 
I have a 03 BMW Z4 where the top will not go all of the way up. It comes up about 1/3 of the way and stops. When I try to put it back down, nothing happens. I either have to release the red handle in the trunk or wait till it gravitates down. The motor works for 1/3 of the way so I assumed that it was ok, Thanks to the great intstructions posted by shipkiller I removed the top to inspect. The hydraulic fluid in the motor seemed low, so I added fluid but it is still doing the same things. My g/f took it to the dealer and they didnt even hook it up to the pc, I was willing to pay the $105 to see what it would say, they said they know it is an electrical issue because the motor is working to take it up 1/3 of the way. Any advice? I am stuck.

shipkiller 07-18-2012 06:45 PM

The motor is working but most likely it does not have enough grunt to get the top all the way up.... unless you have a hydraulic piston issue (very unlikely) then the motor it bad.

brock5ga 07-19-2012 04:52 AM

Quote:

Originally Posted by shipkiller (Post 6959581)
The motor is working but most likely it does not have enough grunt to get the top all the way up.... unless you have a hydraulic piston issue (very unlikely) then the motor it bad.

+1
Have someone grab the top and give it some assist from the moment it starts coming up and see if it will go through full travel. If so, the motor or pump is not strong enough. Some electric motors have an internal circuit breaker that will cut out if the motor draws too much current. Try letting it sit for a few minutes when it quits and see if it will continue, or if you hear the motor try to run for a second. Not sure if these have an internal breaker or not, but you would still replace the motor.

RClonch 07-19-2012 05:15 AM

I have tried to assist it, and regardless it always stops in the same spot. After letting it sit, it settles slowly and when I try to raise it again it always goes back to the same spot (1/3) of the way up. I have tried putting the top up manually and the using the motor to lock it in place, and that does not work either. The dealer stated that it had to be electrical since the motor took it up 1/3 of the way w/ plenty of power, I realize that they could be wrong.I'd hate to spend the money on a motor, and it still not work.

RClonch 07-27-2012 06:31 AM

Replaced the Motor
 
I replaced the motor and am still getting the same result. I also powered up the motor driectly from the battery, bypassing all sensors and it went up all of the way. Therefore I know it is not a motor or a hydraulic problem.

Any advice would be very helpful.

Kugamon 09-11-2012 09:11 AM

I have the same problem!
 
1 Attachment(s)
Just checking to see if you figured out the problem yet. My 2007 Z4 just started doing the same thing.

Using Shipkiller's instructions (thanks from a fellow bubblehead) I pulled the top out of the car. Motor and pump were perfect (I live in a desert), even bench tested strong. Checked roof compartment microswitch-works correctly.

Don't know how to test the Hall sensors but don't know how they could be the problem since the stoppage occurs midway through the travel length and the Hall sensors only kick in at the end of each direction in order to stop the motor at the right time.

However, something seems to know the position of the top since, like you said, it will jump back up to the 1/3 position after the hydraulic pressure bleeds off a bit and the top drops back an inch or two. This was repeatable many times when I continued to hold the "up" botton as the top slowly dropped and would jump back up to the 1/3 position.

I'm tempted to just get a new top control module, but hate to waste $300 to test a theory, especially since I don't know what device is telling the control module the position of the top midway through its travel length. PFM! :mad:

Kugamon - Beer is good food! :drink:

2007 Z4 3.0Si

bten 09-11-2012 07:55 PM

Try lubricating all of the joints in the top. Mine would not get started without a "push" when trying to lower the top.

I opened it up to a point where I could get to all of the rivets that hold it together, and put some light sewing machine oil at each pivot point. Raised and lowered it a couple of times and it works fine now.

I think the motor has only so much power. over time the joints get tight or get dust in them. Easy enough to try.

Kugamon 09-12-2012 10:07 PM

Something more than that.
 
Yup, did the lube thing. When I bench tested it out of the car and applied a straight DC supply to the motor it went through the full travel length nice and strong. It stops at that 1/3 position as if there is some position sensor stopping it at that particular spot. When the oil pressure bleeds off a bit and the top drops back down an inch or so, the motor kicks back in and drives the top back up tp that dang 1/3 open position and stops. Won't go up or down again until the oil pressure bleeds off a bit again. Then it will either go all the way down or up to the 1/3 open position. Screwy thing.

I'm an engineer. I feel I am supposed to be able to figure this stuff out. Eventually I will! Another beer or three and I can solve the worlds problems! If only.

Thanks for the good ideas.

Kugamon 10-01-2012 10:33 AM

Update on Top not going up
 
Here's the latest update on the top issue. Finally took it down to the local BMW dealer to investigate. They say their diagnostics indicate a short somewhere in the electrical harness for the top. OK, sounds reasonable, and could provide the answer to my confusion on why it stops where it does and then starts working again after moving down a bit. The harness is around $65 and will take a few hours for them to replace (that's where the big expense comes in, of course) but I'm pretty much tired of messing with it at this point. The car has been otherwise absolutely trouble-free for the the three years I have owned it so I certainly don't mind spending some cash on it for this, provided it is the cure.

I will report back on how the fix goes.

Kugamon 11-15-2012 08:35 AM

Finally fixed!
 
OK, that was the problem. The wiring harness for controlling the top was bad. After repalcement, the top functions perfectly. Who-da-thunk? Thanks to everyone for the good suggestions!

vietboythoinay 10-03-2014 09:51 PM

Wiring harness short?
 
Hi Kugamon,
Do you remember the exact name/part no. for that wiring harness? My car just had the same problem as yours. I changed the motor and the top went up to 1/3.
Let me know. Thanks

Kugamon 10-06-2014 08:34 AM

Wiring Harness Part #
 
I pulled the invoice for that job. I'm not sure how much of this number is the actual part #, but here is what it sez.

54-34-7-043-906 Cable Harness Folding Top: 54999934

Part was only $56.11 but the labor was $430.50. The harness just didn't look that difficult to replace, but I guess dealerships have high overheads to account for.

Hope this helps you get your top up!:D

vietboythoinay 11-03-2014 08:16 AM

Top Wiring Harness Indeed
 
I finally had some free time to replace the wiring harness (PN: 54-34-7-043-906) for my top after confirming it was not the motor. I called several dealers in my area and none came close to $56.11. They were ~$ 120 :) I ordered online for about $95. I guess the price was increased due to inflation or something like that.

Anyways, I replaced the harness myself and RTV the motor housing as well to prevent water problem in the future. The top works like a champ now.

Million thanks to Shipkiller for his detailed instructions and million thanks to Kugamon for providing me that part number.

It's time to sell my never-used motor :) I bought it at the dealer for $409. It's now $350 if you want to purchase it. I can't return because dealer said it is an electronic part.


All times are GMT -7. The time now is 09:37 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms