Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E30 (1982 - 1993) (http://www.bimmerfest.com/forums/forumdisplay.php?f=96)
-   -   E30 Build Thread (http://www.bimmerfest.com/forums/showthread.php?t=637475)

FenderBender 08-05-2012 06:08 PM

E30 Build Thread
 
What's up guys? I'm Matt, been a member here for years over on the E36 section. I just bought my first E30.

This isn't going to be a build like my turbo Hellrot E36, but nevertheless:



Picked this up for $475 the other day, looking to freshen it up for DD status and possibly sell it for a profit later.

84 318 coupe, 5 speed manual. 210k miles. [(ish) you know how E30s are]


Runs but dies after a second or two, cannot give it any throttle or it dies. Has some rust issues, and needs some other TLC.

http://i359.photobucket.com/albums/o...r/IMAG0657.jpg

http://i359.photobucket.com/albums/o...r/IMAG0658.jpg


http://i359.photobucket.com/albums/o...r/IMAG0660.jpg


http://i359.photobucket.com/albums/o...r/IMAG0648.jpg

Started tearing the interior to see what I have to work with.

http://i359.photobucket.com/albums/o...r/IMAG0656.jpg

Dafak?

http://i359.photobucket.com/albums/o...r/IMAG0651.jpg

PO said there was an alarm system that was removed and he "tied" these blue wires together to make it run. When I pulled them apart, sure enough it wouldn't even crank.


Yanked out a bunch of other wires too, then it would crank and not fire. So I hooked this relay back up and sure enough, she fired up again. I need to look at some wiring diagrams and clean this junk up. Did I mention the lower dash cover had about 6 different wood screws in odd places holding it in?

http://i359.photobucket.com/albums/o...r/IMAG0652.jpg

http://i359.photobucket.com/albums/o...r/IMAG0653.jpg



Started messing with different sensors, unplugged this one and it will idle for probably 30 seconds or so, maybe longer.

http://i359.photobucket.com/albums/o...r/IMAG0659.jpg


Rust in spare tire well, has some on the floor as well. I will probably take most of the interior out soon, I want black seats, door panels, and carpet. I need to secure the gas pedal on the floor as well, not sure how it's supposed to attach though.

http://i359.photobucket.com/albums/o...r/IMAG0661.jpg



Something was a little hungry...

http://i359.photobucket.com/albums/o...r/IMAG0655.jpg


Windows do not work either, but I guess they shouldn't when the switches aren't hook up, couldn't find the wires. Shouldn't be hard to find when the carpet is out. The driver's side door doesn't lock either. I can't do it with the key, or by pushing the lock cylinder down. I'm guessing something is simply seized up. Trunk and passenger door locks work.

I also had time to ohm the MAF, here's a video of it. Based on what I found I'm guessing it's shot as well which would be causing issues. While I'm at it I'm going to replace the spark plugs as well. Eventually I'll do the fuel filter and distributor cap/rotor/etc.

http://i359.photobucket.com/albums/o..._VIDEO0012.jpg


Comments/questions/help is encouraged!

BmwMan92 08-05-2012 11:34 PM

Not alot of people around these parts respond well to m10 318i's to bad your so far i have like 4 good mafs sitting around

_Ethrty-Andy_ 08-06-2012 12:36 AM

welcome to the dark side! yep you picked the worst enginged E30, but i hope that car can keep you in this circle!

E30s are like E36s in that they dont like thier electrics tampered with much. Thats definately an aftermarket relay you pictured. as for that blue wire, it will be on the same circuit as the starter relay and ignition switch.

looks saveable which is good, but as far as selling it on, youd have to sell it to someone that doesnt know anything about E30s etc. not bad for DD status though. at least its manual right?

key bit of advice, the E36 is reletively the same between the start and end of production. the E30 isnt, with a lot of prefacelift bits not compatable with facelift bits etc, in fact the actual shell is different.

i also think putting your M52 in your E36 into your E30 is a fantastic idea :thumbup::thumbup:

FenderBender 08-06-2012 12:52 PM

Quote:

Originally Posted by BmwMan92 (Post 6993045)
Not alot of people around these parts respond well to m10 318i's to bad your so far i have like 4 good mafs sitting around

How come?

Quote:

Originally Posted by _Ethrty-Andy_ (Post 6993079)
welcome to the dark side! yep you picked the worst enginged E30, but i hope that car can keep you in this circle!

E30s are like E36s in that they dont like thier electrics tampered with much. Thats definately an aftermarket relay you pictured. as for that blue wire, it will be on the same circuit as the starter relay and ignition switch.

looks saveable which is good, but as far as selling it on, youd have to sell it to someone that doesnt know anything about E30s etc. not bad for DD status though. at least its manual right?

key bit of advice, the E36 is reletively the same between the start and end of production. the E30 isnt, with a lot of prefacelift bits not compatable with facelift bits etc, in fact the actual shell is different.

i also think putting your M52 in your E36 into your E30 is a fantastic idea :thumbup::thumbup:

Haha, why is it the worst engine? I'm just looking for fuel mileage right now.

I do need to ger a wiring diagram and see what I can fix. There's a relay on the driver's side engine bay that isn't connected either.

Question before I get home, is there a quick connect to check fuel pressure, or what's the best way and what is it supposed to be? 44psi ish?

Pennyw1se 08-06-2012 01:44 PM

According to the Bentley manual, the M10 puts out 101 HP, the 2.7 M20 (found in the 325e) puts out 121 HP, and the 2.5 M20 (found in the 325i) puts out 168 HP.

Keep in mind that those numbers are optimum, straight out of the dealership numbers. You can't realistically expect those numbers from an engine that hasn't had some work done to it in almost 30 years.

FenderBender 08-06-2012 02:30 PM

I'm not looking for hp, my turbo E36 has enough for now. I wanted this car for gas mileage.

BmwMan92 how much for a MAF?

BmwMan92 08-06-2012 02:34 PM

Quote:

Originally Posted by FenderBender (Post 6994126)
I'm not looking for hp, my turbo E36 has enough for now. I wanted this car for gas mileage.

BmwMan92 how much for a MAF?

:thumbup: they don't like them because they are slow but they last forever with very minor problems mine has over 300k and still runs

Urhhm idk if you lived in wa i'd just give it to you haha like 15 plus shipping? Gas money :bigpimp:

FenderBender 08-06-2012 02:39 PM

Does it work perfectly? I'm assuming it will work in my car, still an E30 newb obviously.

I'm perfectly fine with reliable and good mileage and slow, not a problem lol.

ForcedFirebird 08-06-2012 04:25 PM

Welcome to your newest addiction!

Quote:

Originally Posted by _Ethrty-Andy_ (Post 6993079)

key bit of advice, the E36 is reletively the same between the start and end of production. the E30 isnt, with a lot of prefacelift bits not compatable with facelift bits etc, in fact the actual shell is different.

Not totally true. I find the differences in e36's to be similar to the e30. Just today tried to use a clutch master hard line from a 97 in a 94. Bought all new hydraulics and all. If you ever changed the line in an e36, you would know how difficult it is - and how frustrating it is when BMW decided to use a different clip on the newer ones (lines snap in, not screw in).

Shells are the same, but you have OBD1, OBD2, EWSI, II, III etc etc.

FenderBender 08-06-2012 04:36 PM

Uploading fuel pressure video now. It was quite strange, key on is around 30psi unless I turn the key on and off, then it goes all the way up to 80psi, wtf?

FenderBender 08-06-2012 04:37 PM

Also, I found a big vacuum line that goes to the throttle body elbow was disconnected.


Now it will idle sometimes high, sometimes low. Mind you this is with the airbox completely off, Maf disconnected, etc. Another note, I think it's flooding itself. I can start it and let it idle a few times but when it dies I sometimes cannot start it for a few minutes.

FenderBender 08-06-2012 05:09 PM

http://i359.photobucket.com/albums/o..._VIDEO0013.jpg


http://i359.photobucket.com/albums/o..._VIDEO0014.jpg


Don't make fun of my work shoes lol.

BmwMan92 08-06-2012 05:28 PM

Yeah I got a huge box odd extra parts cheap they all work perfectly the guy I bought them from was trying to modify them for performance but they all work fine

FenderBender 08-06-2012 05:46 PM

Pretty sure I'll take a MAF, my zip is 17257. What else do you have?


Here's a vac line I just pulled off the fuel pressure regulator (I think) would a leak cause more fuel or less?


Pretty shot:

http://i359.photobucket.com/albums/o...r/IMAG0673.jpg

_Ethrty-Andy_ 08-07-2012 02:39 AM

Quote:

Originally Posted by ForcedFirebird (Post 6994337)
Welcome to your newest addiction!



Not totally true. I find the differences in e36's to be similar to the e30. Just today tried to use a clutch master hard line from a 97 in a 94. Bought all new hydraulics and all. If you ever changed the line in an e36, you would know how difficult it is - and how frustrating it is when BMW decided to use a different clip on the newer ones (lines snap in, not screw in).

Shells are the same, but you have OBD1, OBD2, EWSI, II, III etc etc.

possibly, i will admit I've never owned an E36 but i have worked on friends ones but proportionally more of my E36 knowledge comes from forums rather than real world experience than E30s which is all hands on. just my experience of the tasks that i have done. then you have the E34 which is a mix of both lol

BMWFatherFigure 08-07-2012 08:59 AM

If the vacuum tube was from the fuel rail: You will have had an air leak so unmetered air drawn in - tending to run weak. The normal fuel rail pressure should not be affected one way or the other at idle. When there is a decrease in vacuum (on acceleration) this will cause the fuel rail pressure to raise and then give a richer mixture - until the higher vacauum is restored.

BmwMan92 08-07-2012 01:32 PM

That I believe is a tank return vacuum line and it depends on what you want to spend lol I still need parts for the eta motor going in the whole running engine is coming out

FenderBender 08-07-2012 03:49 PM

Quote:

Originally Posted by BMWFatherFigure (Post 6995599)
If the vacuum tube was from the fuel rail: You will have had an air leak so unmetered air drawn in - tending to run weak. The normal fuel rail pressure should not be affected one way or the other at idle. When there is a decrease in vacuum (on acceleration) this will cause the fuel rail pressure to raise and then give a richer mixture - until the higher vacauum is restored.

From the fuel pressure regulator to the intake manifold is the one I replaced. Thanks for the info!

Quote:

Originally Posted by BmwMan92 (Post 6996222)
That I believe is a tank return vacuum line and it depends on what you want to spend lol I still need parts for the eta motor going in the whole running engine is coming out


Sent you a PM, need it asap!

FenderBender 08-07-2012 04:10 PM

Took the AFM (MAF, whatever lol) apart to try and clean it to no avail. Here is the video with a better meter, don't pay attention to my friends in the background lol. I did the same slow motion up as I did before.

http://i359.photobucket.com/albums/o..._VIDEO0015.jpg

FenderBender 08-09-2012 03:46 PM

Another video, except of it running.

http://i359.photobucket.com/albums/o..._VIDEO0016.jpg

I installed the new coolant sensor, did nothing. Pulled the plugs, as I suspected I think they're wet with fuel and pretty beat. Bad FPR putting too much fuel into the engine? Or would the no AFM or intake or coolant temp sensor cause the computer to tell it to add more fuel?


http://i359.photobucket.com/albums/o...r/IMAG0680.jpg

BmwMan92 08-09-2012 08:45 PM

Afm I'm sorry I'll send it out asap my car just broke down today and I have no other vehicle at the moment

FenderBender 08-10-2012 06:00 AM

That's alright man the sooner the better.

Sent from my ADR6400L using Bimmer App

FenderBender 08-16-2012 06:15 PM

Any chance you can ship it? Otherwise I'm going to have to find another one, I can't really wait much longer.


Updates:


Videos coming, I'll try and explain what's going on.



The first video (sorry it's kinda long) shows it running on first start up. As you can see, I give it throttle and it dies the first time. Start it up again and I can throttle it decently, the rpms are pretty high but then they start to come down and down until it dies. I keep the throttle steady during this.

http://i359.photobucket.com/albums/o..._VIDEO0024.jpg

After you see me do this a few times, it won't start anymore. I pulled and plug, here's the picture:

http://i359.photobucket.com/albums/o...r/IMAG0694.jpg

The I tested for spark, and sure enough it still has it. So it must be a fuel problem somewhere.


http://i359.photobucket.com/albums/o..._VIDEO0026.jpg


One more thing, here is the connector that comes off the O2 sensor, looks pretty bad. Is there a resistor or anything in there, or should I just cut and re attach?

http://i359.photobucket.com/albums/o...r/IMAG0693.jpg

downhiller 08-16-2012 07:24 PM

the afm helps with the fuel injector pulse. so without that signal, its either flooding or leaning out (i cant remember) the o2 sensor just tells the computer to go from an open loop to close loop for the fuel, which basically means the motor is warming up and doesnt need the extra fuel. so you can unplug it and not cause any harm

FenderBender 08-16-2012 07:40 PM

Man, I need an AFM!!!


All times are GMT -7. The time now is 07:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms