Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E28 (1982 - 1988) (http://www.bimmerfest.com/forums/forumdisplay.php?f=137)
-   -   533i questions (http://www.bimmerfest.com/forums/showthread.php?t=644058)

Ixieboy 09-06-2012 01:06 AM

533i questions
 
I have an 84 533i and I was just curious on a few things
Are there any ways to mount a lighter set of front and back seats?
My fan system and sunroof are both out, looks like trouble under those fuses. Is this common and what can I do to fix it?
Is it possible to get rid of the mass airflow sensor?
Any success with cam timing adjustment?
Speedo and odo are out, tach works just fine; where should I start?
Power antenna is out, is this common as well?


I would appreciate any help I could get

south26 09-06-2012 04:41 AM

1. Are there any ways to mount a lighter set of front and back seats?
When yousay lighter do you mean in color or weight. Your seats are manual, instead of the later electric, so they are already rather light. I am not sure but I believe the e30 manual sport seats might be a little lighter. If you want a lighter color well there are different interiors.

2. My fan system . Ehn you say fan do you mean the one for the air or the one fore the heat? Both do tend to die. If the one for the heat you h ave to replace the one behind the firewall. There are 3 differnt kinds, so you have to pull it out before buying one. IF the one for the AC you have to take apart the center consul to get to it.

3. sunroof are both out, looks like trouble under those fuses. Does it move at all? or does it just get stuck? It could be that the nut is loose in the motor. Youcan tighten it with the allen wrench that can with the car. If it does not move at all it could be that the motor is dead, I do have one for 15 plus shipping. \

4. Is it possible to get rid of the mass airflow sensor? It is a AFM not MAS, you would have to change the a lot to get rid of it. Also do not both getting another airbox because unless you pay a lot the factory one is the best .

5. Any success with cam timing adjustment? Not sure

6. Speedo and odo are out, tach works just fine; where should I start?
Power antenna is out, is this common as well? This is common the instrument board starts to die because of age and there are small batteries on the board which leak and damage the board so things stop working. You can either buy another cluster and put it in or you can take it apart and get another mother board and put it back together.

Ixieboy 09-08-2012 10:04 PM

lighter as in weight. i want to be able to have front and back seats, but not the heavy ass horse hair and leather ones. something cloth and cheap preferably.

well, honestly, both. i wanna delete the clutch fan and my ac/heater thing is out. the whole panel is gone. the sunroof went at the same time because they are on the same fuses. looks like the panel below them was a little melty, but no major damage. should i just check it or replace it regardless?

i have a cheap cone filter on, is that worse than factory? i havent noticed a power boost, but the engine does run cooler with it.

well, the speedo is more intermittent than gone. when the heater worked or on a sunny day when the dash warmed up it starts working, on sharp bumps it kicks on for a few seconds.

is there a way that i can test the power antenna? also, is it wired to go up when the car is on or is there some button i am missing?

south26 09-09-2012 05:38 AM

Quote:

Originally Posted by Ixieboy (Post 7062409)
lighter as in weight. i want to be able to have front and back seats, but not the heavy ass horse hair and leather ones. something cloth and cheap preferably.

With the back seat, I would guess no, they only weigh around 25lbs each. (I have shipped a few) With the front seats there other seats that you can put in, but you might have to fabricate seat spacers so that you can bolt them into the bolt holes.

well, honestly, both. i wanna delete the clutch fan and my ac/heater thing is out. the whole panel is gone. the sunroof went at the same time because they are on the same fuses. looks like the panel below them was a little melty, but no major damage. should i just check it or replace it regardless?

Why do you want to delete the fan clutch? Unless you are putting an electric one on. The engine needs this fan to help it keep cool. The ac is a different fan from the heater. I am assuming that when you say the panel is melted you are talking about the fuse box. What is happening is the old secondary fan in front of the radiator is not turning as well as it should so it is drawing more juice so it is melting the fuse box. You need to take the secondary fan off and take off the fan. Remember the nut is reverse threaded so when you tighten you are loosenng, then lube it up with a good grease. (not wd-40)

i have a cheap cone filter on, is that worse than factory? i havent noticed a power boost, but the engine does run cooler with it.

It is worse then factory, it is infact drawing warm air from the engine bay, the factory one draws better.

well, the speedo is more intermittent than gone. when the heater worked or on a sunny day when the dash warmed up it starts working, on sharp bumps it kicks on for a few seconds.

This is your instrument cluster slowly dieing.



is there a way that i can test the power antenna? also, is it wired to go up when the car is on or is there some button i am missing?

It should go up when you turn the radio on. with another person turn on the radio and have a person listen to see if they hear the motor turning. It might just need a new mast. The masts have a bad habit of getting stuck. If that is it you need a new mast. You have to remove the old one before buying a new one because there are 2 different kinds of masts. One has teeth and the other is smooth. You remove it by undoing the 10 mm bolt that is holding the mast in. Then tunr on the radio and pull up on the antennae mast at the same time. This should get it out. You put the mast in in reverse of taking it out.


Andy

Ixieboy 09-09-2012 02:28 PM

Quote:

Originally Posted by south26 (Post 7062680)
It should go up when you turn the radio on. with another person turn on the radio and have a person listen to see if they hear the motor turning. It might just need a new mast. The masts have a bad habit of getting stuck. If that is it you need a new mast. You have to remove the old one before buying a new one because there are 2 different kinds of masts. One has teeth and the other is smooth. You remove it by undoing the 10 mm bolt that is holding the mast in. Then tunr on the radio and pull up on the antennae mast at the same time. This should get it out. You put the mast in in reverse of taking it out.


Andy

well, it does have an alpine stereo in it, could have been wired wrong as well. do you perchance know which wires are for the antenna on the dash side?

catso 09-09-2012 04:55 PM

Your intermittent speedo and odometer problems might also be caused by worn plastic gears. It's a rather common problem in lots of older BMW's and you can buy replacements if you want to DIY.

Ixieboy 09-09-2012 10:45 PM

Quote:

Originally Posted by catso (Post 7063617)
Your intermittent speedo and odometer problems might also be caused by worn plastic gears. It's a rather common problem in lots of older BMW's and you can buy replacements if you want to DIY.

i would love to do it myself, any idea on where i could get ahold of these parts other than the stealership?

catso 09-10-2012 12:02 AM

Quote:

Originally Posted by Ixieboy (Post 7064161)
i would love to do it myself, any idea on where i could get ahold of these parts other than the stealership?

Check out this link:http://www.bimmerfest.com/forums/sho...d.php?t=622429

Ixieboy 09-10-2012 09:51 PM

Quote:

Originally Posted by catso (Post 7064229)

heck yes! ill take a look to make sure its the gears before i order a set.

what do i have to do to delete the clutch fan? ive been meaning to install a set of electrics that i got from a pick and pull, but they arent an 1/8th of an inch thick.

ive also been looking into the coil and wires, is it a dizzy or a coil pack? the last two sets of spark plugs ive checked wouldnt fit the wires, even though they fit the head.

south26 09-11-2012 04:38 AM

Not sure but when you saythe spark plugs would not fit the wires, do you mean the spark plugs would not fit on? If so did you try taking the silver part off the end?

BMWFatherFigure 09-13-2012 04:01 AM

Alpine head units have an antena motor wire and work fine with BMW power aerials. Masts jam alot. Changing is easy, as above. Radio fitters and alarm/imob installers are loom wreckers with black tape. ID the wire by colour code at the ends - it does not change.
SI batteries; gears and the little capacitors on the logic board (if the batteries have not burst and buggered the PC board). I saw changing them on another forum - fairly easy.
Fix that lot and I think the dash will work fine.


All times are GMT -7. The time now is 05:28 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms