Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   Beisan M62TU VANOS kit is released! (http://www.bimmerfest.com/forums/showthread.php?t=649064)

Nervous 09-30-2012 02:24 PM

Beisan M62TU VANOS kit is released!
 
Just heads up: the so much anticipated and delayed M62TU VANOS kit is released by Beisan and available on their website! I've already ordered one, along with tools and press.

http://www.beisansystems.com/products.html

LaCrosse540i6 09-30-2012 03:24 PM

Quite a bit more involving than the m52tu/m54 rebuild! I think I would give it a shot if I ever have to do my guide rails.

bluebee 09-30-2012 04:09 PM

I'll add a cross reference to the bestlinks.

Here's what's there now for the M62:
- BMW M62TU engine VANOS seals DIY (1) & how to make your own VANOS tools (1) & socket tools (1) & how to objectively test VANOS seals in operation (1)

DoubleDO954 09-24-2014 05:09 AM

Which Besian vanos seal products to buy?
 
Hello All,
I want to buy the replacement vanos seals from BesianSystems.com , from the advice of previous threads on here. Looking on the products page, I think these items are the right items:

S54/S62 Vanos Rattle Tools $20 (not sure on this one)
M62TU Vanos Seals Repair Kit $60
M62TU Vanos Extra Teflon Ring $20

My plan is to take them to the local german BMW service center to get them installed. I had an issue with a fast ticking sound on the engine passenger side, but since I replaced the spark plugs and rev'd it to near red line it hasn't ticked for the past 2 days. So do I have the right items? Should I add/drop any??

1998 BMW 540iA M62
108K miles

edjack 09-24-2014 10:20 AM

Your engine should be an M62, and does not have VANOS.

The ticking may have been a loose tappet. Your redline may have pumped it back up.

Were any plugs loose when you removed them? If so, that may have been the noise you heard.

BMW specifies the NGK BKR6EQUP plug for all E39 models.

Burning2nd 09-24-2014 03:46 PM

lol This reminds me of a addict, just jonesing for the next hit,

Well... There will be a reduction in M62tu's that run on this site,

In other news

S420 09-25-2014 01:57 AM

K ? Your engine should be an M62, and does not have VANOS
 
no Vanos M62 ?

Quote:

Originally Posted by edjack (Post 8608165)
Your engine should be an M62, and does not have VANOS.

The ticking may have been a loose tappet. Your redline may have pumped it back up.

Were any plugs loose when you removed them? If so, that may have been the noise you heard.

BMW specifies the NGK BKR6EQUP plug for all E39 models.


DoubleDO954 09-25-2014 05:22 AM

Regarding mine, Ed is right. My 540 prod. date is 11Jun1997, so I have the M62B44 engine. Vanos was added in 1998 with the M62TUB44 engine. (all according to Wiki)

Mechanic said the spark plugs were in good conditions, nothing about any being loose.

Definitely jonesing. Loving the ride, but I want smoother, faster, gas sippinger..


All times are GMT -7. The time now is 08:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms