Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E38 (1995 - 2001) (http://www.bimmerfest.com/forums/forumdisplay.php?f=156)
-   -   Navigation display recently went out! (http://www.bimmerfest.com/forums/showthread.php?t=649985)

BimmerBro 10-04-2012 08:47 PM

Navigation display recently went out!
 
Well this sucks! Apparently the navi LCD just went out because I can still play the radio/cd player but it automatically powers off every five minutes and I have to turn it back on.

I found out the Navigation unit is in the trunk and no lights are on it. I guess this means the unit is bad? I've searched on Ebay and the prices are 400 bucks. Anyone find the Navi unit any cheaper?

thanks

sealbeach740 10-08-2012 03:52 PM

Definately sounds like your Nav unit is toast.
I don't know the seller, but it looks like others have had pleasant experiences when buying from him, and the price is fantastic for a MKIV!
http://www.bimmerboard.com/forums/posts/1107205

Of course, if you want to go a less expensive way, you should be able to find a MKII for much less, and a MKIII for just a little more.

BimmerBro 10-10-2012 08:05 PM

From the posts around here, it's seems the smartest way to go is MKIV. Thanks for the link. I'm starting a little savings fund right now to get a new unit!

chrisn7 10-11-2012 05:56 AM

Mk4 is the way to go-DVD based instead of CD, also later software up to v31 release, allowing splitscreen and perspective viewing. Also 7 digit post (zip) code input

dannyb1027 10-11-2012 06:20 AM

This is a long shot but try cleaning the navigation disk. a dirty disk can cause some strange things.

Myronmhouse 10-16-2012 10:20 PM

do you have the 4:3 or widescreen? If you have the 4:3 you can get a cheap 4:3 tv tuner and just hook it up.

You'll get everything except the navigation ( all menus) and your stereo won't shut off after 2 minutes. That will give you more time to search for a nav unit.

If you already have a tv tuner, just unplug the blue plug from the nav unit and plug it into the tv tuner.

Bw740 10-17-2012 05:54 AM

Hello everybody am new to this fourms. I had the same problem last week. Checked nav drive smelled like smoke burning wires, thats after i got my window tintted. So i found a place in sacramento this guy soled the navi screen 16.9 and drive mk3 for $250 pluged them in working grreat..........

sealbeach740 10-21-2012 10:41 PM

You got a MKIII & a 16x9 installed for only $250?
Now that's a smokin' (pun) deal!!

Bw740 10-22-2012 06:39 AM

Yep but anyway i have an extra navi display that i am selling if there is any one interested.....


All times are GMT -7. The time now is 04:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms