Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   2006 E66 DCS/ABS/Servomatic/ faults (http://www.bimmerfest.com/forums/showthread.php?t=650258)

baltej 10-06-2012 01:43 PM

2006 E66 DCS/ABS/Servomatic/ faults
 
1 Attachment(s)
When I start my car there is no fault lights, i will begin to drive for about 10miles or so and the abs fault light appears, followed by the servomatic malfunction, and DCS inactivated. I had the car service codes read which read as a abs/speed sensor, so i replaced both front sensors $200 dollars later no change. I had the battery checked from autozone at 700cca,750cca, 850cca load and battery stayed at 80% under load. I had the alternator checked from a shop and they said its working fine. couple of things left to check, the steering wheel angle sensor, and the DCS module. So I would appreciate any input in to finding the problem and how to test them to check if its functioning, the shop i went to just feels like they will just have me replace everything until the problem is fixed regardless if its working or not. Attachment 344584

MINI+BMWtek 10-06-2012 03:01 PM

I recommend to hook up with ISTA and have any faults that come up in test shedule review by a BMW technician. Ch

Sent from my Nexus 7 using Bimmer App

MINI+BMWtek 10-06-2012 03:01 PM

Ch

Sent from my Nexus 7 using Bimmer App

MINI+BMWtek 10-06-2012 03:02 PM

Check alternator with a DSO during start up,high load and ch

Sent from my Nexus 7 using Bimmer App

MINI+BMWtek 10-06-2012 03:03 PM

Also look for any loose battery connections

Sent from my Nexus 7 using Bimmer App


All times are GMT -7. The time now is 02:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms