Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   New Member Introductions (http://www.bimmerfest.com/forums/forumdisplay.php?f=129)
-   -   2001 330i (http://www.bimmerfest.com/forums/showthread.php?t=651402)

goober69691967 10-12-2012 08:46 AM

2001 330i
 
hi i have a 2001 330i 3.0 ,,, we just did an engine swap ,the car ran perfect before the old motor blew up ,, we changed the block and head only , every sensor and injector and wire that was in the car is still in it ,, the new motor has about 50,000 miles on it , has 180 lbs compression across the board ,, and extrealy clean inside ,, we put it all together and the motor has a surge in it ,the idle fluctuates up and down ,, it will also run with the exaust cam sensor unpluged but it throws a code ,, we plug it back in and clear the code , and it still fluctuates ,,,, no codes , no lights , runs great except for the idle going up and down ,,,we are sooooooo frustrated , we need fresh eyes to look at this , what could it be please help,,,,,,thanks

Fast Bob 10-12-2012 10:03 AM

Did you try cleaning the Idle Control Valve ? MAF cleaner works well for that. If they`ve never been changed, there`s about a 100% chance that your VANOS seals are toast. Stop by the E46 Forum and start a thread for yourself. Good luck !


All times are GMT -7. The time now is 01:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms