Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E38 (1995 - 2001) (http://www.bimmerfest.com/forums/forumdisplay.php?f=156)
-   -   Radio Issues (http://www.bimmerfest.com/forums/showthread.php?t=656520)

Celthorseman 11-06-2012 12:15 PM

Radio Issues
 
Ok this is driving me nuts. My radio works part of the time, but me CD player works all the time. Here is what I mean, I start me car in the morning and I have AM/FM and tape, but once it warms up all I have is CD. Even if I am listening to the radio and it goes out I change the channel and it works again, but only for a little while. The LD and SB or little up, but the SB is dimmer than the LD on the tape area. Also with that I just put a new tape player in the car. I am thinking of going with an after market set up, but I really like the look of the factory system, so that is a last resort. Any thoughts on what I might be able to do to make the radio work all the time?

BMWFatherFigure 11-06-2012 06:31 PM

Remove the ignition switch electrical part. Drown it in switch cleaner and work the switch through its range. Wash again and dry. Refit. Should fix it. Full reasons on other of my posts

Celthorseman 11-07-2012 08:00 AM

What is the other post that you talk about this fix in. I must say it sounds weird to me to fix this issue this way. Then again I have seen stranger things in the past.

Sent from my DROID3 using Bimmer App

740lman 11-21-2012 03:11 PM

Are you saying remove the switch assembly? Or can you drowned the key switch (where the key goes)? I my case the radio seeming to stop and the screen seems to lock up. I just bought the car and I am still learning all the gadgets.

chrisn7 11-22-2012 05:24 AM

You remove the switch assembly from the steering column, dis-assemble and clean. Its a straightforward job and there are fewer parts inside the switch than you might imagine.

BMWFatherFigure 11-24-2012 12:50 AM

The switch has a volt only signal to several componemts. contacts oxidise because of low current. cleaning fixes. DONT squirt switch cleaner down the key hole. Where did you get that?

chrisn7 11-24-2012 08:43 AM

Agreed. The contacts inside have small amounts of grease to ease their movment. The last thing you want to do is spread that around via switch cleaner. The contacts are similar to, though smaller, than the old contact breaker points for those who remember such things....

bmw2qnj2le 12-08-2012 10:35 PM

2001 740i. Lost Multifunction display
 
2001 740i. New with the E38/740i car.
I lose my NAV/Radio/Multifunction display after disconnecting my battery for replacing the oil cover gasket.
When I reconnected the battery back, my display was blank. I called for help. Helper is not familiar with BMW. I could not started my car b/c I set the security code. After reading the manual, I could start my car again but still no display. Radio only works for ~3 min then stops.
1. Any thing I can do to bring back the multifunction display back? (the back light does work)
2. Do I need to take to dealer to fix it? or just any simple fuse or reset somewhere in the car that I could do?

Any help is greatly appreciated. Many thanks in advance.

bmw2qnj2le:yikes:

740beemer 01-13-2013 09:09 PM

I have a couple of questions, i just got a 1996 740il and the radio wont work i dont know what it is i thought it was the speakers so i replaced them but it still did not work i dont know if its the radio or the dsp, the dsp will not turn on but the radio does, can someone help me?

BMWFatherFigure 01-13-2013 10:22 PM

Not a problem I have come across - sorry

740beemer 01-14-2013 11:04 AM

Thanks anyways

HneDog 02-20-2013 02:05 PM

i got similar problems with my 98 740il with no nav. my cd work great but my radio doesnt. everything turns on and when i try to find a station for am and fm it cant lock onto a channel.

http://www.youtube.com/watch?v=0qaYvgUU304

740beemer 02-20-2013 04:22 PM

Well i found out the problem to why my radio was not working, there was no amp and i was thinking about buying a oem amp but i just decided to buy a after market radio and now i can listen to my music. First off is there noise coming from the speakers and second is the antena conected

HneDog 02-21-2013 12:58 PM

Quote:

Originally Posted by 740beemer (Post 7393841)
Well i found out the problem to why my radio was not working, there was no amp and i was thinking about buying a oem amp but i just decided to buy a after market radio and now i can listen to my music. First off is there noise coming from the speakers and second is the antena conected

if i turn it up all the way i can hear white noise. and isnt the antenna on the back of the head unit ( cassette player )???

where is this stubborn piece of garbage in the car?


All times are GMT -7. The time now is 02:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms