Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   1998 528i Speedometer Not working! (http://www.bimmerfest.com/forums/showthread.php?t=657872)

Chaoul1 11-13-2012 07:28 AM

1998 528i Speedometer Not working!
 
I have a BMW 528i and the Speedometer isn't working. All I found while searching around was that it could be the ABS Sensor or the DSC Module. Are these the two possiblities? I heard that if it is the DSC Module, I can get it rebuilt. If it's the ABS Speed Sensor I'll replace that myself. Any suggestions as to what it would be?

I'm at school now driving my Jeep. The BMW is at home and I'll be home at around 5:30. I'll check and see what lights are on/off.

Will bringing it to advanced auto parts help tell me what's happening? I don't feel like going to the dealership where the rate is $150 to do a Diagnostic check.

Everything else works great. Nothing else is wrong with the car except for the Speedometer not working.



Thanks!

cn90 11-13-2012 07:39 AM

Likely bad speed sensor (mounted at the wheel hub).

black528i 11-13-2012 11:50 AM

Wheel speed sensor on the left-rear wheel, see part #24 at RealOEM.

Chaoul1 11-13-2012 01:32 PM

I hope so. Will a scan tool from advance auto parts being up a code? Ill look at it once I get home from school and see what lights are on again.

Thanks guys!

AntsE39 11-13-2012 03:38 PM

I dont believe there scanner can read that deep into our cars.

Anthony

Chaoul1 11-13-2012 05:25 PM

I'll buy the wheel sensor and see if it works! Thanks for the help!

black528i 11-13-2012 06:49 PM

Make sure you get an OEM one. It will save you the time and the hassle of returning the cheap one that doesn't work.

Chaoul1 11-14-2012 11:14 AM

Okay so everything is good! Thanks, but I got another problem.....I have a check engine light. I got the code. It's P0319 which is a Rough Road Sensor A- Circuit Malfunction. What do I have to replace now?

mlnotl 11-14-2012 12:39 PM

Hi:
My 2000 528i has been showing the Abs sensor light in the dash and now the speedometer and odometer are not working. I have had the car checked and the sensors looked at but that doesn't seem to be the problem. Could it be a short somewhere or a loose wire?

black528i 11-14-2012 12:41 PM

DTC Codes P0300-P0399 are for Ignition System or Misfire in OBD II. Thats all I could find.

Chaoul1 11-14-2012 01:40 PM

Quote:

Originally Posted by mlnotl (Post 7194894)
Hi:
My 2000 528i has been showing the Abs sensor light in the dash and now the speedometer and odometer are not working. I have had the car checked and the sensors looked at but that doesn't seem to be the problem. Could it be a short somewhere or a loose wire?

Did you replace the Left Rear Speed Sensor? How did you check?


All times are GMT -7. The time now is 03:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms