Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   X 5 abs dsc and yellow brake all on. (http://www.bimmerfest.com/forums/showthread.php?t=657995)

Cbegley1 11-13-2012 05:06 PM

X 5 abs dsc and yellow brake all on.
 
hello I have been doing a ton of reading on here. The other day I was backing out of a parking space and the ABS engaged I was going pretty slow and I knew that's what it felt like. The trifecta appeared. I cleaned all the wheel sensors. I've even checked the ABS module with the ohmmeter everybody Recommended. . I tried unhooking the battery to reset the three lights. I left it unplugged for 24 Hours and the lights are still on. I did the turn the wheel to the right to the left back to the right again and that Did not reset the lights either. Like I said before I tried reading everything on here that I could understand and I have followed the steps and checked and double checked. I'm just lost now. Anybody have any good suggestions of where I should go next besides this stealership? Thanks so much. 2001 bmw x5 4.4

DirtyDan 11-15-2012 08:42 PM

My brother just had this happen to his 2000 740i and it is the Abs/dsc module located under the hood. The X5 and the 740i have the same 4.4i motor. You can send yours in and have it rebuit by Module Master which costs $300 plus shipping and no recoding is needed that way. My brothers module ended up not being able to be recoded so he had to buy used one from a salvage yard and then had it recoded at his local BMW shop for his car. Now no lights on.

http://www.modulemaster.com/en/index.php

DirtyDan 11-15-2012 08:48 PM

here is a write up link http://forum.roadfly.com/threads/131...asters-and-DIY

Cbegley1 11-15-2012 09:01 PM

Thanks for the reply
 
Thanks for the reply my buddy has a friend who works at a dealership and had that special code reader. It said front left sensor. I've done a lot of reading on here and people have said that the 2 front sensors are interchangeable and I took The one from the right side and put it on the left. The lights went off I backed out of the garage and I felt the abs kick on. Then the abs lights were back on. So I'm thinking the computers hard code was for the left and I replaced it with the right and it was good so the computer does a recheck every time the car is started. I think I got it. I ordered 2 new sensors for the front. I'll post and let you know in a few days. Thanks again

itscoo2pyopants 08-24-2013 07:18 AM

X 5 abs dsc and yellow brake all on.
 
Any update?


Sent from BimmerApp mobile app


All times are GMT -7. The time now is 01:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms