Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E34 (1989 - 1995) (http://www.bimmerfest.com/forums/forumdisplay.php?f=102)
-   -   1995 525i engine runs rough (http://www.bimmerfest.com/forums/showthread.php?t=658356)

jbarry54 11-15-2012 10:49 AM

1995 525i engine runs rough
 
Hi Bimmerfest,

I have a 1995 525i e34, m50 engine. The engine lacks power and runs really rough until I hit about 3000 rpms and then it gets somewhat better, but still rough. Attempted the stomp test with zero results. Someone suggest that it's the idle control valve but this rough running is not at idle. Yesterday, while acceleration onto the highway, it just bogged down and would not go forward. I had to shut the car off, it restarted and I was able to get home. I did pull the MAF out and used MAF cleaner on it. That did not make it better. Any suggestions would help.

Monsignor 11-15-2012 11:08 AM

Quote:

Originally Posted by jbarry54 (Post 7196812)
Hi Bimmerfest,

I have a 1995 525i e34, m50 engine. The engine lacks power and runs really rough until I hit about 3000 rpms and then it gets somewhat better, but still rough. Attempted the stomp test with zero results. Someone suggest that it's the idle control valve but this rough running is not at idle. Yesterday, while acceleration onto the highway, it just bogged down and would not go forward. I had to shut the car off, it restarted and I was able to get home. I did pull the MAF out and used MAF cleaner on it. That did not make it better. Any suggestions would help.

Check your plugs for oil in case you have a leak which could be fouling them up and subsequently the coils.
Check your air filter, such a simple thing with such a big job.
Good on you cleaning the MAF that would also have been in the list.

jbarry54 11-16-2012 05:40 PM

Thanks!
 
Thanks for your reply, I will attack the Beemah in the morning.

jbarry54 11-27-2012 03:30 PM

Thanks 95 E34!
 
Quote:

Originally Posted by 95 E34 (Post 7196843)
Check your plugs for oil in case you have a leak which could be fouling them up and subsequently the coils.
Check your air filter, such a simple thing with such a big job.
Good on you cleaning the MAF that would also have been in the list.

Found the leak in the spark plug tubes, removed and replaced the valve cover and spark plug gaskets, got new boots, and air filter. Thanks for your reply. She's running like a brand new E34.

I owe you a couple cold ones. Have a happy and safe holiday season.

:thumbup: Bravo Zulu.

BMWFatherFigure 11-27-2012 04:34 PM

Love a story with a happy ending.......................

Monsignor 11-28-2012 11:58 AM

Quote:

Originally Posted by jbarry54 (Post 7217572)
I owe you a couple cold ones. Have a happy and safe holiday season.

Very happy to hear it!! :thumbup: Careful with the offer, Lancaster isnt too far from me, may just take you up on it one of these days ;)


All times are GMT -7. The time now is 03:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms