Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   dripping anti-freeze (http://www.bimmerfest.com/forums/showthread.php?t=658572)

Mr.750 11-16-2012 12:45 PM

dripping anti-freeze
 
My 06 750I is leaking anti-freeze like a cow that hasn't been milked all day! I have no idea where it is coming from, as when I look under the hood all the hoses I can see are fine, and I have no idea what else it could be. Everytime after driving(15 miles or so) I have a puddle of anti-freeze thats big enough for a family of goldfish to survive in. Any ideas? :dunno:

1bad540 11-16-2012 12:58 PM

check the lower rad hose the sensor o ring usually goes.

Mr.750 11-16-2012 01:06 PM

Quote:

Originally Posted by 1bad540 (Post 7198736)
check the lower rad hose the sensor o ring usually goes.

Where are they located? will I have to take covers off?

SFbay 11-16-2012 01:12 PM

Could be a wheep hole as well
Or hoses, waterpump, expansion tank

1bad540 11-16-2012 01:32 PM

underneath the car.

allaboutthelife 11-16-2012 01:56 PM

I had the same issue, mines was the O ring sensor on the lower rad hose like @1bad540 stated. The part cost me $43 and installation $70! I love this forum.

First_745Li 11-16-2012 01:57 PM

Quote:

Originally Posted by BMW750IMMIA (Post 7198712)
My 06 750I is leaking anti-freeze like a cow that hasn't been milked all day! I have no idea where it is coming from, as when I look under the hood all the hoses I can see are fine, and I have no idea what else it could be. Everytime after driving(15 miles or so) I have a puddle of anti-freeze thats big enough for a family of goldfish to survive in. Any ideas? :dunno:

Sorry to hear that...check this link out

http://www.bimmerfest.com/forums/sho...d.php?t=651616

Rookie2008 11-16-2012 03:50 PM

Also remove the 6 bolts on the engine cover an right in front of the throttle body is a 3 prong plugs. Make sure its not leaking.

hd750Li 11-16-2012 06:51 PM

I didn't have a leak but just replaced the o-ring when I flushed the coolant as a preventative method. It costs $3 at HomeDepot.:thumbup:

Mr.750 11-16-2012 08:16 PM

Thank you for all that helped! Of course, you were right. :thumbup: However you figured out it was that exact part out of the 228,836 in this car, I give you props.


All times are GMT -7. The time now is 05:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms