Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E34 (1989 - 1995) (http://www.bimmerfest.com/forums/forumdisplay.php?f=102)
-   -   Headlight Malfuction (http://www.bimmerfest.com/forums/showthread.php?t=658678)

blueice164 11-17-2012 07:29 AM

Headlight Malfuction
 
I am having problems with my low beam lights on my 1990 525i,They will be working fine and all of a sudden they will just go out.I can turn on high beam and they will work fine,but that doen't work too well for on coming cars.:) Oh I changed multifuction swtich that didn't fix.

BMR_LVR 11-17-2012 08:49 AM

Quote:

Originally Posted by blueice164 (Post 7199703)
I am having problems with my low beam lights on my 1990 525i,They will be working fine and all of a sudden they will just go out.I can turn on high beam and they will work fine,but that doen't work too well for on coming cars.:) Oh I changed multifuction swtich that didn't fix.

Welcome to the Fest Blueice.

I'm not all that good with electrical stuff, but I remember that the light control module (LKM) can go wonky and cause problems like yours. I did a brief search of the net for the LKM and here is a link that may be helpful:

http://bmw4life.com/lkm.htm

I'm sure that there are others as well. At least you know of the proper search term (BMW LKM, E34 LKM etc.) to search for.

Hope this helps. Good luck and let us know how it turns out or what the eventual fix was.

Again, welcome.

south26 11-17-2012 02:42 PM

have a good lkm for 25 plus shipping


Andy

BMWFatherFigure 11-18-2012 05:33 AM

IS there a relay that could be going bad? Just a thought.

blueice164 11-18-2012 04:58 PM

Thanks for all the great advice, I will try the LKM this week and let you know if this fixes the problem. Steve AKA blueice164

blueice164 11-30-2012 08:26 PM

Thanks BMW_LVR South26 and BMWFatherFigure for the great advice.Replaced the LKM and it seems to have fixed that problem.

BMR_LVR 12-01-2012 08:05 AM

Quote:

Originally Posted by blueice164 (Post 7224349)
Thanks BMW_LVR South26 and BMWFatherFigure for the great advice.Replaced the LKM and it seems to have fixed that problem.

:thumbup:


All times are GMT -7. The time now is 01:25 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms