Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E60 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=104)
-   -   Bad water pump? (http://www.bimmerfest.com/forums/showthread.php?t=658712)

maggasp 11-17-2012 12:21 PM

Bad water pump?
 
Yesterday my '08 535 overheated (40k mi). First I noticed that there was no heat through air vents, then the radiator fan turned on very high, then the overheat.

I've read a bunch about replacing the thermostat and water pump together, but I'm just trying to diagnose whether the pump is bad and I need to spend the $400 on that part.

I initiated the water pump bleed procedure, and the pump turns on and circulates some coolant, but it sounds very weak to me.

Please take a listen/look at my video and let me know if you think if the pump is working properly.

http://youtu.be/u9s9U3Fw590


Thanks

legend700 11-17-2012 09:18 PM

Mine sounds exactly like yours. I am having it replaced along with the thermostat, on Monday. Parts and labor by an indy $800. My car has close to 36K miles on it. I noticed the noisy pump after replacing the coolant and during the bleeding procedure. Luckily noticed it before an overheating incident.
I would not start the car again unless pump and thermostat is replaced.

maggasp 11-19-2012 10:16 AM

Thanks for the response. I just bought the parts ($500) online, so it sounds like $800 all in at your indie is a good deal.


All times are GMT -7. The time now is 02:04 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms