Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X3 E83 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=65)
-   -   Burn smell x3 2.5i (http://www.bimmerfest.com/forums/showthread.php?t=658863)

hyper_x3 11-18-2012 09:07 AM

Burn smell x3 2.5i
 
I have noticed that when i roll down the windows and accelerate heavily, there is a burn smell that appears (fire works smell). I am not sure where its coming from and it only appears when i full throttle it or heavily accelerate. Any one has this problem or knows the solution?

alpinweiss 11-18-2012 09:23 AM

Could you give us a bit more information on your X3?
1. What is the year model?
2. How many miles (kilometers) on the odometer?
3. Is it manual or automatic transmission?
4. Have you had any recent repair work done on your X3?
5. Is there any unusual noise when you accelerate and have the burning smell?

Hello, and welcome to Bimmerfest!

:drive:

hyper_x3 11-18-2012 09:26 AM

its a 2005 automatic. Has 147,000km. no mechanical repairs and no sounds. just smell.

mlukas161 11-18-2012 10:10 AM

I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passanger side if the valve cover.

alpinweiss 11-18-2012 11:05 AM

Quote:

Originally Posted by mlukas161 (Post 7201398)
I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passanger side if the valve cover.

To the OP: If your valve cover gasket set has never been replaced, it is overdue. It will now be hard and brittle. The set includes the valve cover gasket plus the seals that go around the spark plugs. This will cause a burning oil smell, if it is leaking. You may also want to replace your spark plugs as a part of this job.

Since you mentioned the smell is present only when you accelerate, I wonder if there may be something driveline-related. Have you had the fluids changed on the transfer case and both differentials? The transfer case is especially critical. Follow this link:
http://www.bimmerfest.com/forums/sho...d.php?t=463848

It is a bit hard to diagnose a smell by long distance, but I hope this helps on your problem.

:drive:

hyper_x3 11-18-2012 10:24 PM

thank you very much for your help. I haven't changed the cover neither the spark plugs. I will check with the diferential oil. I hope this solves my problem thank you againg.

Sent from my GT-I9300 using Bimmer App

hyper_x3 11-18-2012 10:25 PM

thank you for your help, I will see if that solves my problem.

X3-terrestrial 11-20-2012 08:18 PM

Quote:

Originally Posted by mlukas161 (Post 7201398)
I would guess its a leaking valve cover gasket. Oil may be leaking out and burning. Look for oil on the passenger side if the valve cover.

X2 on the Valve Cover Gasket!

At that mileage, you need to get serious on catching up on maintenance!

-All fluids (Transfer case, transmission, both differentials)
-Valve Cover Gasket
-Spark Plugs
-02 sensors
-Fuel Filter
-Air Filter
-Brake fluid flush
-Coolant flush
-Power steering fluid flush
-Shocks and struts must be screaming for help too!


All times are GMT -7. The time now is 07:32 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms