Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E34 (1989 - 1995) (http://www.bimmerfest.com/forums/forumdisplay.php?f=102)
-   -   Cold crank problems (http://www.bimmerfest.com/forums/showthread.php?t=659954)

sueing77 11-23-2012 04:18 PM

Cold crank problems
 
1 Attachment(s)
My 525i won't crank or start in mornings when it is cold outside. Do anyone know why?

virgontour 01-04-2013 10:23 PM

some batterys give up to cold weather when they get old in the tooth

paperplane94 01-04-2013 10:43 PM

Yeah, the best thing you can do is remove the battery and take it to your friendly local auto parts store where they should test it for free. There they will tell you if it needs to be replaced or not.

robertobaggio20 01-04-2013 11:00 PM

If the battery checks out, then it is your cps. Crank sensor. The cold resistance is out of specs....replace it anyway, it will go bust.

snowsled7 01-05-2013 05:57 AM

Battery, cables, starter. The CPS has no bearing on an engine not cranking. This is most likely the battery. Have it tested as suggested. I agree that it is not uncommon for cold weather to kill a battery.

robertobaggio20 01-05-2013 06:23 AM

Oops misread. Yeah if there is no crank, then battery, fusible link and starter.

macgy 01-09-2013 04:57 AM

+1 on starter


All times are GMT -7. The time now is 11:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms