Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   X5 E53 (1999 - 2006) (http://www.bimmerfest.com/forums/forumdisplay.php?f=22)
-   -   2001 x5 4.4 starts then dies.....HELP!!!! (http://www.bimmerfest.com/forums/showthread.php?t=661383)

blakey2000 11-30-2012 11:53 AM

2001 x5 4.4 starts then dies.....HELP!!!!
 
my 2001 x5 4.4 will start then dies everytime, throwing these codes:

P0120 = Throttle/Pedal Position Sensor/Switch 'A' Circuit
P0123 =Throttle/Pedal Position Sensor/Switch 'A' Circuit High
P0223 = Throttle/Pedal Position Sensor/Switch 'B' Circuit High

my scantool will not erease them nor will sitting w/ battery unplugged overnight.

I replaced the petal assembly and throttle body with new equipment, HELP!!!

blakeyatwork@yahoo.com
919-417-4448

someone please text me or email me!

blakey2000 12-01-2012 05:16 AM

do I need to recalibrate or rellearn the throttle system, seems like it? process?
 
do I need to recalibrate or rellearn the throttle system, seems like it? process?

blakey2000 12-02-2012 12:28 PM

P0120 Throttle/Pedal Position Sensor/Switch A Circuit Malfunction
P0121 Throttle/Pedal Position Sensor/Switch A Circuit Range/Performance Problem
P0223 Throttle/Pedal Position Sensor/Switch B Circuit High Input

blakey2000 12-12-2012 07:10 AM

2001 x5 still starts then stops!
 
10 days later same issue.

start up and then shuts off after 1-2 seconds

Codes:

P0120
P0123
P0223
P0103


relplaced ecu from ecudoctors and synced ews
new throttle body
new gas pedal

HELP!!!!!!!!!!!!!!!!

blakey2000 12-13-2012 01:33 PM

....help!
 
...me!

blakey2000 12-26-2012 07:58 AM

Hey guys Im still down . I know a guy with DIS (bmw software) but he wasnt sure if there was a step in the software that Im missing that makes the pedal talk to the throttle. Right now I have the ecudoctors DME, perfect wires and harneses from pedal to DME, DME to throttle body and a new pedal and throttle. Still showing to high of voltage to throttle codes.



Does DIS have a step in it Im missing. I get the initial open/shut on turn of key of the throttle body but no 10 or 30 second initialization process w/ the key seems to do anything.

blakey2000 02-10-2013 07:24 AM

WELL its fixed, cost me 2600$ to figure it out but to save aeveryone trouble, replace the computer (DME) first then if that doesnt fix it its the MAF as well. That combination worked for me. If you do that itll only cost you 1000$


All times are GMT -7. The time now is 04:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms