Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   Idle adjustment? (http://www.bimmerfest.com/forums/showthread.php?t=661407)

Bennt771 11-30-2012 01:39 PM

Idle adjustment?
 
Is there anyway to self adjust the throttle a tad higher on a 2000 540i?
I did read somewhere (cant find it now) that you can but not sure where to do it?
My idle is at 400ish at idle when warm. And it surges a bit when its cold. No codes present.

Also are the peake code readers better than the Innova i normally use for these BMW's?

hh3uunp 11-30-2012 02:29 PM

Get INPA and ncs expert. It's an electronic TB so that's the only way to do it

JimLev 11-30-2012 03:29 PM

No mechanical adjustment for the idle. It can be raised if you connect into the DME, however it shouldn't be surging. Fixing that may bring the idle up to where it should be.
Have you ever cleaned the throttle body and MAF. Also check all of the ducts from the MAF to the throttle body for cracks, same for the vacuum lines under the top engine cover.
Not sure what Innova you have but most OBD readers are better, quicker, and easier to use than a Peake, IMHO.

poolman 11-30-2012 06:14 PM

You got some work to do--clean the throttlebody and search and find where you have vacuum leaks--that the problems your facing--not bad--just gotta do some work

Bennt771 02-13-2013 03:54 PM

So, it seems i found my issue. MAF i guess it was on its way out. Car has not stalled and its been 2 weeks now. Tried a aftermarket one and it was crap. Ordered a Bosch and all is good. I posted wht was going on because it is rare that members do.

edjack 02-13-2013 05:13 PM

Thanks for the feedback. Sadly, you are correct.

Bennt771 02-13-2013 06:30 PM

:)

Five30Eye 02-13-2013 06:49 PM

Would an idle, halfway between the first mark and 1k be abnormal? :dunno: Too high? It's an auto.

Bennt771 02-13-2013 07:07 PM

If yours is reading correctly, it seems a little high. But i would not worry about it much. The only thing i have read about the idle being to high is related to the throttle body. Have you messed with it ??? Have you cleaned it??

Five30Eye 02-13-2013 09:02 PM

No, haven't touched the intake system. Replaced VCG, that's all. Idle didn't change before/after, been at 750 (I guess) since I bought the car. Doing a DISA rebuild this weekend, I'll check the hoses closely. Think I need CCV for good measure and restful sleep.


All times are GMT -7. The time now is 12:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms