Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E39 (1997 - 2003) (http://www.bimmerfest.com/forums/forumdisplay.php?f=103)
-   -   Missing CRANK position sensor!? (http://www.bimmerfest.com/forums/showthread.php?t=661511)

barneyhyphen 12-01-2012 06:48 AM

Missing CRANK position sensor!?
 
1 Attachment(s)
'98, build date 01/98 528i stick.

started pulling the fan shroud etc off this morning, in order to do my VANOS seals BUT, 10 minutes in, discovered the molded ,metal ring/hoop/"bracket" which, I assume, is designed to accept the CRANK position sensor, is there, BUT the sensor itself is AWOL. Not even any apparent floating wires or plugs????

Should it be there OR is this a redundant bracket as the sensor is elsewhere or am I actually missing the sensor. Can't believe it would be running if it's actually not there!

Have had the car for 4 years/82,000 miles and have never been anywhere near the CPS, or should I say the empty bracket!

Any help would certainly be appreciated, thanks.

BH

ACS-B 12-01-2012 06:59 AM

FYI the crankshaft position sensor is mounted into the rear of the engine block, on the driverís side below the starter motor.

barneyhyphen 12-01-2012 07:19 AM

Well, that's certainly good news. So, what's that bracket there to hold?

BH

ACS-B 12-01-2012 07:38 AM

Quote:

Originally Posted by barneyhyphen (Post 7224826)
Well, that's certainly good news. So, what's that bracket there to hold?

BH

I believe that for previous engines (m50s, m20s... but not m52 and above) that is the location of the crank sensor.


Here is a link to the location of the pulse generator aka crank position sensor on my wife's m54:


http://www.realoem.com/bmw/showparts...11&fg=10&hl=34

Takechan 12-01-2012 07:57 AM

You sure you don't have a M52TUB28 and not an M54?

Mine is exactly where your one seems to be missing. I have an M52B25.

I'm pretty sure the location is exactly the same on the TU. This (part no. 9) is where it is located on a generic 528i from 01/98 manual.

http://www.realoem.com/bmw/diagrams/d/f/1.png

09 Pulse generator, crankshaft 1 09/1998 12141703277 $116.05

Flybot 12-01-2012 08:45 AM

Normal. My 98 528 has the same thing.

moots 12-01-2012 04:20 PM

Quote:

Originally Posted by barneyhyphen (Post 7224781)
'98, build date 01/98 528i stick.

started pulling the fan shroud etc off this morning..........

BH

errr.....yr a/c belt is all cracked up......your fan belt too i assume?if yes...that is priority rather than the vanos seals!

my m52b28 has the crank pos sensor fitted there......http://i962.photobucket.com/albums/a...1/P3040169.jpg

ACS-B 12-01-2012 04:32 PM

Quote:

Originally Posted by moots (Post 7225567)
errr.....yr a/c belt is all cracked up......your fan belt too i assume?if yes...that is priority rather than the vanos seals!

my m52b28 has the crank pos sensor fitted there......http://i962.photobucket.com/albums/a...1/P3040169.jpg

I assumed he was replacing the belts as part of the vanos seals DIY


As for the crank position sensor it may be a US market thing as I see you are in Malaysia

ACS-B 12-01-2012 04:33 PM

Quote:

Originally Posted by Takechan (Post 7224874)
You sure you don't have a M52TUB28 and not an M54?

Mine is exactly where your one seems to be missing. I have an M52B25.

I'm pretty sure the location is exactly the same on the TU. This (part no. 9) is where it is located on a generic 528i from 01/98 manual.

http://www.realoem.com/bmw/diagrams/d/f/1.png

09 Pulse generator, crankshaft 1 09/1998 12141703277 $116.05

The difference may be due to US specifications being different

bluebee 12-02-2012 03:22 AM

There's not much on the CKP in these forums so I assume it's a very reliable part.

Here's what I found typing /ckp F3 in the bestlinks:
- How to replace the V8 crank position sensor (CKP) crankshaft pulse generator (1)

Note there is nothing on the I6.

Takechan 12-02-2012 08:42 AM

I replaced mine three times...

1st time: Replaced with non-OEM, did not help
2nd time: Installed OEM no error
3rd time: New engine

The CPS is connected below the intake manifold, which is a PITA to connect/disconnect. If you have a thin arm, you can try to remove the oil filter cap and use your arm.

Please see the instructions from TIS here.

You can see it more clearly below, from when I swapped my engine:

http://i49.tinypic.com/33jr38n.jpg

http://i50.tinypic.com/jjwr9i.jpg

barneyhyphen 12-03-2012 07:17 AM

Thanks all the responses, very much appreciated.

Changed out the VANOS seals and gasket, VCG and rubber VC boly washers, along with both belts and the upper tensioner roller/wheel. All went well and is now running like a champ.

Concluded that what I had assumed was the crank PS bracket was redundant. Thanks everyone's input on that.

have now done my daughter's 2000 323i double VANOS and my 98 E39 single. Can advise that the VANOS seals can be done, without the required "special tools" although it is a little more tedious. The only "thing" I had to jimmy together was a bolt on jig to hold the VANOS pistons in the correct plane, for the E46.

BH

EthirtyMine 01-10-2013 09:47 AM

I just went through a bunch of stuff with my ckp. When the new sensor didn't help, I *assumed* that there was a break in the wiring somewhere.

You know what happens when someone assumes, don't you?

I bought p/n 12514592703 (listed as "adapter lead" under #8, but not shown:
http://realoem.com/bmw/diagrams/y/u/73.png).

Notice where it says, "See SI 122701000"? So did I, and even after hours of searching, I turned up bupkis. Well, almost: there was a German Language forum that showed in google results, but I didn't bother clicking because I haven't studied German in 12 years, and just *assumed* (see a pattern here?) that the whole thing would be in German, that google/babelfish would translate it as a dissertation of subcutaneous play-doh injection of stuffed animals.

Weeks later, I click on it anyway, and lo, there it was: the original service bulletin that talks about a CKP recall where the old M52 CKP is replaced with the newer, 12-volt CKP that arrived with the advent of the M52TU. Which explains why I couldn't figure out what to do with the damned thing: I didn't need it!

So, perhaps what you are seeing are the vestiges of a successfully executed recall? I dunno; I was just so stunned to find that pdf that I had to post it somewhere.

E36 Phantom 01-10-2013 11:41 AM

Wow old thread.

That's an artifact of older engines. M50s have it there, M52s left the bracket in place but buried it back by the starter. All M52s are like that.

Sent from my LG Revolution 4G using BimmerApp

bluebee 01-11-2013 05:37 AM

I'm very confused about the location of the CKP in the E39 because the location shown above does not seem to be anywhere near where it seems to be in the V8 as per this thread:
- > E39 (1997 - 2003) > What is this engine part? (Getting to know my M54 engine bay)

Quote:

Originally Posted by bluebee (Post 6926370)
This is not really a picture inside the engine bay, but ...
http://www.bimmerfest.com/forums/att...1&d=1341029085
Circled is the CKP (crankshaft position sensor) ... not to be confused with the CPS (camshaft position sensor) ... from JimLev's post in this thread just now:
-> E39 (1997 - 2003) > Crankshaft position sensor location


bluebee 01-22-2013 01:51 AM

2 Attachment(s)
The I6 folks on the E46 side has this to say about getting to the CKP today:
Quote:

Originally Posted by EthirtyMine (Post 7327277)
FWIW, I just went through this. I couldn't find an experience like mine already documented here, so this is more for posterity than anything else.

I had P0335 and P0727 on my 11/99 528iT (m52TU and A5s360r).

When you have your CKP (crankshaft sensor) out, with the air channel and the microfilter housing removed and a strong flashlight, you can see down the hole in the block through which the CKP is mounted.

Put a ratchet on the crank on the front of the motor.

While peering into the CKP hole, turn the crank (from the front of the car, clockwise) and look at the teeth on the impluse sending wheel. There should be a space where the teeth are absent, about the size of 2-3 minutes on a clockface, that is normal. If there is more than one spot without teeth, or if the toothless spot is large and/or has broken, jagged edges, the most likely scenario is a broken/damaged impulse sending wheel.

This was the case for me. To get to it, the motor has to come out, and by the time you tear down the engine to get to the crank, you might as well just put in a good quality lower mile used motor instead of replacing the bleepin' $40 impulse wheel.


EthirtyMine 01-22-2013 04:20 AM

Quote:

Originally Posted by bluebee (Post 7329094)
The I6 folks on the E46 side has this to say about getting to the CKP today:

Bluebee, you've got an m54 now, right? Here are some great photos of an immaculate, out-of-the-car block and where the CKP goes.
http://www.bimmerboost.com/images/im...ov201167-1.jpg
http://www.bimmerboost.com/images/im...ov201168-1.jpg

A couple different ways to get at it:
- One poster did it from underneath the vehicle, by feel alone. Maybe I drink too much coffee, but my dexterity doesn't even approach being able to do that.
- Someone else did it by removing the airbox, MAF and rubber boot to the throttle body.
- To me, I felt I had better access by removing the driver's side microfilter and air channel. Then, with a 5mm long reach ball-end hex socket, like this, it's pretty easy to reach.

It occurs to me that if you really want a good look at it, and an easy reach, you could remove the fender liner and jack up the front of the car (so that the wheels drop to their lowest point of travel) and you would probably have a straight shot to it. Seems like more trouble than it's worth, though.

Make sure you have a magnetic pick-up tool when you take it out.

When you go to re-install it, stretch a piece of electrical tape over the tip of the ball-end hex socket to hold the bolt in place while you guide it to the hole.

bluebee 01-22-2013 04:40 AM

3 Attachment(s)
Quote:

Originally Posted by EthirtyMine (Post 7329186)
you've got an m54 now, right? Here are some great photos of an immaculate, out-of-the-car block and where the CKP goes.

Yes I have an M54. And that is a fantastic set of pictures:
- Technique Tuning Stage "PEI330Ci" 330i Turbo Street Car

I see there are quite a few of those very nice pictures here:
- Bimmerboost

To help all M54 owners, I took the liberty of annotating them to add to this thread:
- In situ pictures of common parts of the M54 engine (1)
http://bimmerfest.com/forums/attachm...1&d=1358858544

Quote:

Originally Posted by EthirtyMine (Post 7329186)
A couple different ways to get at it

That is fantastic advice for the next person who needs to replace their CKP!
http://bimmerfest.com/forums/attachm...1&d=1358858644

EthirtyMine 01-22-2013 06:46 AM

Forgot to mention, that while you have it out, get a strong flashlight and put a ratchet on the crank. Then turn the crank by hand and inspect the impulse sending wheel for damage as it turns by shining the light into the hole in the block. A damaged impulse wheel will send the same code as a faulty CKP sensor. I checked the resistance on three different CKPs and got three different numbers; for that reason I do not feel that measuring ohms for these is a suitable indicator of their operability.

Also, it's A LOT easier to plug and unplug the pigtail with the sensor unmounted. I wouldn't even bother trying to (un)plug it while it's in there.

Get the area clean before removal. I took electrical contact cleaner and a detail attachment for a shopvac (basically a 3/8" hose) and got it spotless first. CAUTION: NEVER VACUUM FLAMMABLE LIQUIDS. FIRE AND/OR EXPLOSION WILL OCCUR. I made sure my contact cleaner was non-flammable before prepping the area.

You can test a CKP sensor by observing the voltage fluctuation that occurs when the motor cranks. However, for my car at least, the only way I could have done that and still kept the rest of the ecu wiring harness plugged in would've been to remove those specific pins from the connectors.

If I were to flowchart this in the interest of, say, an algorithm, these would be my steps and the order in which I would undertake them:

1. Remove and visually inspect CKP. Check for cracks and any marks indicating the impulse wheel may have made contact.
2. Turn the crank by hand and inspect the impulse wheel. There is a small smooth spot with no teeth, that is normal. Look for roughness that would indicate cracking and fracturing.
3. With the CKP unplugged, now check for continuity between the harness-side connector and the wire-loom connector to the ECU.

If your impulse wheel is okay and you have good continuity (no breaks) in the wires to the ECU, then it's probably your CKP.

petch 10-04-2013 02:57 PM

Hi - this is a great post about the M54 crankshaft sensor and exactly what I needed. I replaced the sensor but now found out the problem lays with the connecting cable between the sensor and a junction box mounted on the engine that I guess also has a cable to the cam sensor plus other leads. The car will crank but not fire unless the cable is moved or pulled away from this junction box. Your great photos don't quite include the box and I cannot reference it or the cable in realoem.com google or the forum. Anyone know any part numbers, any links please or do I just have to make a new cable somehow? Thanks

bluebee 04-03-2014 10:40 PM

This is good information to cross reference to the OEM thread:
- What BMW E39 parts & supplies are most often recommended to buy OEM from a dealer or sponsor (1)
Quote:

Originally Posted by mjbennett9 (Post 8254798)
Passing on some info--consume it how you will. Not sure what to make of it all, but here goes.

Purchased my car over two years ago, maybe 2 and a half. Has always run well, not great, not perfect. Ok power etc but just ok, you know. I didn't really have anything to compare it to. I bring this up because later it makes sense--sort of. Fast forward to now, and nothing scientific cuz incrementally I've done things to car over the years, but nothing for months prior to CPS work. In the past year or so, come to a fast stop, the car has or almost stalled for no reason (in my mind). About a month ago, I get a check engine light, check code. it was exhaust CPS I think (one without the built in wire). So I ordered both just in case. I ordered OEM but not original. One was meyle and the other MTC (one of which looked just like BMW but was scratched off). See pic. Anyway, replaced and code gone asap. AND, a good bump in performance/power. Noticable. But was it 20% or 30%, probably not. maybe 10% to 20%, but enough that for a while I was getting whiplash stepping on gas because I would step on it harder than normal as I always did. But doing that would propel car forward more than before. Good right? yes, sort of. My mileage, is and has pretty much been at 31 to 33 on the highway and 15 to 16 city. When I got the code it dropped about 5% or so. With new CPS sensors (both), mileage dropped 20%!!! I put old sensors back, mileage back to just the 5% drop. I ordered both OEM Original, boom, mileage right back to 31/33 and 15/16. Again, not sure what it means other than the obvious to only use OEM Original for CPS (which others have stated before). But it is interesting that the code was fixed, and I did get a performance boost. BUT, mileage took huge hit.

Also to note. the non-original sensors took a LOT of force to get them to fit. OEM original slid right in. The non-original screw hole didn't line up perfectly as well. Original-perfect.

http://www.bimmerfest.com/forums/att...5&d=1396574718
See also:
- How to replace your camshaft position sensor (CPS) in the E39 (02 530i) (98 540i) (M62 98 540i) (98 528i) (530i) & E46 (1) & ('99 740iL)
- How to locate, access, and replace the CKP crank position sensor in the I6 (1) and the crankshaft pulse generator in the V8 (1)

bluebee 07-11-2014 10:47 AM

By way of cross reference, this thread was posted today...
> 5 Series > E39 (1997 - 2003) > P0339
Quote:

Originally Posted by bem-ster (Post 8456179)
I know that a P0339 fault code refers to an intermittent crankshaft sensor circuit A. I can't find a Crankshaft Sensor for a 2001 525i engine. I know the Exhaust Cam Sensor is located on the passenger side of the vehicle just under the exhaust solenoid attached to the Vanos assemble. Is there a Crankshaft Senor on this particular vehicle? I was under the impression the A circuit refers to the Intake Cam Sensor and NOT the Exhaust Cam Sensor



All times are GMT -7. The time now is 07:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms