Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E60 (2004 - 2010) (http://www.bimmerfest.com/forums/forumdisplay.php?f=104)
-   -   Surprise !!!! (http://www.bimmerfest.com/forums/showthread.php?t=662160)

blksphrwit19 12-04-2012 11:17 AM

Surprise !!!!
 
My 05 525i has 97k miles and I just got an increased emmissions on my screen and im feeling hesitation when im driving can anyone help and tell me what i could be looking at when I roll into the dealer this week ?

SoLucky 12-04-2012 12:12 PM

Do you have a code reader? A friend with one? Or can you stop by an auto parts store that will read the codes for you? When you have the codes, post here and we'll diagnose. Could be as simple as a worn out O2 sensor...

MRV99 12-04-2012 10:55 PM

I had this error many years ago and it was a air injector pump of some kind. This happened many years ago on my 545

BayAreaE60530i 12-05-2012 12:06 PM

similar problem for me was a misfire in one of the cylinders. Had to replace spark plugs and ignition coils. $900 (dealer parts)

luckydog 12-05-2012 09:31 PM

When i had that code it was failed secondary air pump to cats. There are two on my car one leaked and failed. If you can just get the code read the repair s can be DIY with the book.


All times are GMT -7. The time now is 08:12 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms