Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   Cd changer doesn't keep selection (http://www.bimmerfest.com/forums/showthread.php?t=662451)

wjjklj 12-05-2012 06:43 PM

Cd changer doesn't keep selection
 
When I play a cd say #5 cd and turn off the car, the cd goes back to the #1 cd. Anyone else have this issue? I can play any cd I want with the car running but it goes back to #1 after sitting.

samadkins29 12-05-2012 06:46 PM

Yes, but randomly. I might have to try it with the #5 cd. Every now and then it will be back to 1. Cant remember if its happened after the replacing the battery or not. Nothing positive to diagnose yet.

KingSilverback 12-05-2012 08:15 PM

Battery Gremlins lol this started happening before my battery got super weak and I had to replace it, easy way to find out if its your battery is to charge it overnight then see if it happens when the battery is fully charged, if it doesn't then it's definitely your battery

Sent from my SPH-L710 using Bimmer App

cmpcpro 12-05-2012 08:57 PM

It could be your car is not going into sleep mode and sensing a power drain. Then when restarted it will re-initialize the changer.

wjjklj 12-06-2012 12:17 PM

Battery is new and registered. The alternator and power module are new too.

First_745Li 12-06-2012 01:01 PM

I have this issue... thought replacing the battery would have solved it. Happens after the car has been parked for about two hours. It cycles thru the CDC and starts at CD1 and I notice when I open the doors (doors were unlocked being parked in the garage) the dome lights don't come on until I insert the FOB.

SuperSnoop 12-06-2012 03:10 PM

With a power issue, I'd expect the radio to switch to a different source entirely, rather than just revert back to cd-1. Does it take a while to start playing, like it's checking for the presence of each disc first?

wjjklj 12-06-2012 04:59 PM

Quote:

Originally Posted by SuperSnoop (Post 7235066)
With a power issue, I'd expect the radio to switch to a different source entirely, rather than just revert back to cd-1. Does it take a while to start playing, like it's checking for the presence of each disc first?

No it starts right up just starts on disc 1 track 1. Not a huge deal and only happens when the car has been parked overnight. Just kinda annoying.

SFbay 12-07-2012 08:58 AM

Quote:

Originally Posted by wjjklj (Post 7235211)
No it starts right up just starts on disc 1 track 1. Not a huge deal and only happens when the car has been parked overnight. Just kinda annoying.

Check if your L7 is coded to your car.

First_745Li 12-10-2012 08:48 AM

Quote:

Originally Posted by SFbay (Post 7236183)
Check if your L7 is coded to your car.

What software would I use to do that?

drzhuang 01-15-2013 02:46 PM

I am having the same problem lately. Even though it does not prevent the CDC from working properly after it goes through the whole CD magazine one disk after another, I worry this could shorten the life of the CDC significantly as it changes the discs much more frequently than the case in normal use.

I called BMW service center and was told that this wouldn't be covered by BMW Extended Warranty. Damned.

Please help if you have good suggestion to fix this.

Tanny 01-15-2013 02:55 PM

I have this problem when I have a cd or radio playing and i turn off the car and I start the car again it reset to nothing playing. It doesn't seem to be holding memory. Is that my battery?

sirstopher 01-15-2013 03:35 PM

Quote:

Originally Posted by wjjklj (Post 7235211)
No it starts right up just starts on disc 1 track 1. Not a huge deal and only happens when the car has been parked overnight. Just kinda annoying.

Mine does the same thing, check your eq and l7 settings in the idrive and see if they reset also.

sirstopher 01-15-2013 03:36 PM

Quote:

Originally Posted by wjjklj (Post 7234790)
Battery is new and registered. The alternator and power module are new too.

Mine too, all new.

Tenn 01-16-2013 05:16 AM

Let's face it...THE CDC system in the 7 SUCKS and are full of FAIL! Thank goodness for SAT and the separate single CD player ... Repair/replacement $1400. to fail again?

First_745Li 01-16-2013 05:53 AM

From what I've read from other threads, its a battery drain somewhere which I haven't been able to figure out. I thought it was the phone in the center console - took it out same results. I then thought it was the light for the overhead vanity mirror in the back - bc one time I noticed it was on even tho the little door was close... I checked all the light switches in the visors to see if those were staying on and no all good there. I've just been dealing with it, a bit annoying I must say.

wjjklj 01-16-2013 06:56 AM

I have noticed too lately that when opening my trunk the light takes like 10 seconds to come on. Don't know if it is related or not. Maybe the battery drain problem but the car has a new battery, new alternator,and new power module....no other symptoms.


All times are GMT -7. The time now is 03:50 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms