Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E65 / E66 (2002 - 2008) (http://www.bimmerfest.com/forums/forumdisplay.php?f=126)
-   -   2002 BMW 745li gives a Fault in Pass-restraint system (http://www.bimmerfest.com/forums/showthread.php?t=662814)

AlSmith1964 12-07-2012 05:24 PM

2002 BMW 745li gives a Fault in Pass-restraint system
 
So I have the message “2005 BMW 745li gives a Fault in Pass-restraint system” a friend of mine told me to replace the seat belt receiver, so I did. I used INPA and cleared the codes. Well the error came immediately back. I cleared them again and immediately the error came back again. Any suggestions, is it the pressure mat? I would really like to find a solution. Thanks.:mad::dunno:

rippjd 12-09-2012 09:45 AM

2005 model year has a 10 yr extended warranty on the seat occupancy mat. I had mine replaced recently at no cost. There is a SIB on the topic.

asanti128 12-09-2012 10:43 AM

Try a new battery and register it. Clear code. Low voltage throws that code. Happened to my 7

Sent from my DROID RAZR using Bimmer App

AlSmith1964 12-09-2012 01:04 PM

I have a new battery, the car is a few months over 10 years, but I'll call the dealer it cant hurt. Will DIS tell me what part to replace?

KaileSvick 12-12-2012 09:40 PM

Its usually the mat in the seat that goes bad

AlSmith1964 12-13-2012 02:30 PM

Ok, I'm convinced it's the mat. Does anyone know how hard it is to replace?

rsbolin@me.com 12-13-2012 05:09 PM

Could be the safety terminal from the battery change. I have heard of that throwing a code.

KaileSvick 12-13-2012 07:14 PM

Quote:

Originally Posted by rsbolin@me.com (Post 7248504)
Could be the safety terminal from the battery change. I have heard of that throwing a code.

If im not mistaken, when the safety terminal has the problem it shows up with a drivers airbag fault message instead of the passenger.

nick2481 12-29-2012 03:59 PM

It could be the control module. I had the same error on my car. 02 745li. After a new control module the software might need updated.

AlSmith1964 12-29-2012 06:32 PM

Quote:

Originally Posted by rsbolin@me.com (Post 7248504)
Could be the safety terminal from the battery change. I have heard of that throwing a code.

I changed the battery, now the alt went out waiting to see what happens after install. Will keep advised. Thanks for the input!

Davidf 12-30-2012 08:27 AM

"Passenger" in this context means all occupants. Not passenger vs driver. So, the fault does not tell which the problem is on. It could b anything and you need to use INPA to find the problem. On my 5, it was the driver side door module. Everyone wanted to blame the seat sensor, but that was not the problem.

los2much 12-30-2012 09:59 AM

if you replace the seat from a salvage yard would it fix the problem

AlSmith1964 12-30-2012 04:25 PM

The mat is only $80 I'm going to buy it new after I replace the Alt. The Alt was $269 rebuilt. Thanks for the advice!


All times are GMT -7. The time now is 04:22 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms