Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E34 (1989 - 1995) (http://www.bimmerfest.com/forums/forumdisplay.php?f=102)
-   -   Yet another EML + ASC Light Question... (http://www.bimmerfest.com/forums/showthread.php?t=663808)

xRyan 12-13-2012 12:00 AM

Yet another EML + ASC Light Question...
 
Hello,

I recently purchased a 1992 535i. It has the 5 speed Getrag, as well as the dreaded 'Drive by Wire' (Elektronische Motorleistungsregelung).

I purchased the car knowing it had the EML issue, thinking following a few different guides (can't post links because I am 'new') on cleaning the TB would solve the issue.

Originally the TB wasn't returning to close fluidly, so I followed the guide, as well as got to the internal gearing and lubricated everything.
Perfect, the TB now opens and closes fluidly.

I reinstall everything, and as per the PDF I remove the negative for a few hours, and then followed the 5000rpm three times and idle.

EML Light is still on, as well as the ASC light will kick on after a minute to a couple minutes.

Is there any other solution/direction I should be leaning towards to fix this issue?
The car still has issues like; surging idle, when cruising at a fixed speed the car pulses and accelerates a few MPH, then lets off. (Think like hitting accel button when using cruise control)
As well as just a lack of power in the top end; above ~4k

I really appreciate any pointers, as I've reached the depths of what google search had to offer me.


All times are GMT -7. The time now is 04:50 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms