Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   7 Series - E38 (1995 - 2001) (http://www.bimmerfest.com/forums/forumdisplay.php?f=156)
-   -   2000 bmw 740il radio dead. (http://www.bimmerfest.com/forums/showthread.php?t=665993)

darrelljr00 12-24-2012 06:52 PM

2000 bmw 740il radio dead.
 
I recently bought a 2000 bmw 740il for CHEAP.. as a project. It starts right up.. runs ok ect.. Anyway

WHen I bought it. The CD CHANGER, and AMP were disconnected in the trunk and the Navigation screen and radio/ cassette were disconnected up front in dash..

WHen I connect the harness for the amp and I put the key in ignition position (1) I hear a LOUD humming noise from ALL speakers.

When I connect the harness for the radio in The small red light comes on, and cassette can be heard moving but blank navigation screen, no sound. nothing.


I checked all fuses and all are ok. Please help ..

BMWFatherFigure 12-25-2012 09:00 PM

Try the ignition swith clean trick. Works more times than not. PM me if you need more info.

darrelljr00 12-25-2012 09:04 PM

Do I use electronics parts cleaner? Also is cleaning it the alternative to replacing it?

BMWFatherFigure 12-26-2012 09:26 PM

I'll see if this info can become a sticky for E38. Are you sitting comfortably with a coffee - good. The E38 has a multi layer wafer ign switch. One of the layers sends a VOLTAGE to radio/nav etc systems to get them into stand-by mode. The CURRENT is so low the contacts oxidise over time. It has been known that turning on the sun visor vanity lights can fix the problem as they use the same contacts. To fix: Remove the electrical part of the switch and take it out of the car. Drown it in switch cleaner and operate it over its full range a number of times. Wash it out (with the cleaner) an blow dry with compressed air. Refit and all should be well. If not it's another problem on the same circuit. Then you will have to trace with voltmeter etc..

sinaiflash 12-31-2012 08:42 PM

I have a 97 740 il and the radio works every once in a while. When it does work all it takes to shut it off is to step on the brake or turn on the lights. Sometime when i hit a bump it will come on. When it does it will not come on after you turn off the car. When it works it sounds great. I don't know where to look, if the rear of the radio were accessable with out tearing out the dash, that's where i'd start. I think that this is a common problem with this model and that someone out there can tell me what to look for. I'd love to get it fixed

darrelljr00 01-01-2013 05:23 AM

After cleaning the ignition switch the radio still doesn't power on. All I see is the orange light ..navigation screen still dead

sinaiflash 01-01-2013 07:12 AM

I wish i knew. What makes it tough is the lack of accessability. Please let me know if yopu figure it out.

darrelljr00 01-01-2013 10:53 AM

Well, Im going to just bite the bullet and buy another head unit and see if that fixes it. I hope it does though

sinaiflash 01-01-2013 12:10 PM

[FONT="Arial Black"]well i have been in the garage all night fooling around with the radio, fuses and the stuff in the trunk. My fuses are ok. I almost had the cassette player out but after you loosen the 2 little screws behind the little doors on either side of the cassette, it still won't come out. Now i could probably get it out if i didn't care about the dash and those damned little clips. It hangs up on something on either side and the trim on top. So then i tore up the trunk. Without having the test equipment or replacement parts it's just busy work. I'd take it to an auto stereo store but most of them are kids working in the shop and they don't care about how they wire things up and you can't watch them and once they clip it it's clipped for good. That's what is really keeping me from having it fixed. Bmw shop is way too high for this type of work unless they can hook something up to your system and tell you right off what the trouble is. Changing parts until you find it is no way to do it. I am still sure that this is a common problem with these cars, just like the glove box latch. I kinda know a parts guy at the bmw shop and i'm going to take him to lunch, send him a pizza or something and see if he can ask his tech's what the common problem is. If you find out before me let me know and i'll do the same.

darrelljr00 01-01-2013 02:28 PM

If I knew someone else locally with a BMW I could just ask them to plug mine in and see if it works. Even better, If I knew which pin was which on th back of the radio .. I could just put a 12volt battery to it and see if the navigation screen lights up. Since I beleive the amp, and radio receiver in the back and the cd changer are kind of inter-connected, and I just bought this car with no history if its electrical health, I really feel like Im starting at ground zero, I dont know what works and what doesnt. amp makes buzzing noise and the cd changer is missing the cd magazine and also it looks like some idiot removed 1 of the harnesses that plugs into the back cd changer.. LOL..

sinaiflash 01-02-2013 02:49 PM

More 740 il radio stuff
 
well i did that thing with the bmw guy. He is going to ask the guys at the dealership what are the common problems with the radio's and where to look for them. He's going to do this as he can get to it. When i hear from him i'll let you know what they say. By the way if this ever comes up, on the 97 740 il there is only one cam position sensor. The later models have 2. Let me know what works for you.
sinai flash

darrelljr00 01-11-2013 05:12 PM

UPDATE.. So I went ahead and bought a used bmw 740 gps radio from someone and it worked .. Screen works. radio works. BUt still I can hear that LOUD buzzing distortion noise in ALL speakers. So I also think my DSP AMp is no good. But here is my questions. How could the radio and also dsp amp be broken?

tdoe602 01-11-2013 06:36 PM

Sound like a bad ground. Check the wires by the CD changer and amp. U found some corroded wires on my 1998

Sent from my Zio using Bimmer App

sinaiflash 01-11-2013 07:20 PM

Darrelljr00. Good that you got it working. Here's the thing with my setup. The cassette accepts the tape and you can here it run it switches channels and ejects the cassette, the radio goes to the station that i want but neither of them play. If my radio was broken the cassette should still play. The cd cartridge was stuck in the player and i had to pry it out, so that's probably no good. When i hold the weather button down with the key onto accessory, it first tells me the s/n for the radio then it says "no station" this is what the manual says to do to test the radio. Keep in mind sometines the radio will play. If i turn on the lights,hit the brake or hit a bump it stops. There are the diversity module, antenna amp, fm amp, and the amp, radio reciever that could be the problem. I don't know if the dealer can just plug in a scanner and it tells them what is wrong. I wonder if there is a compatable aftermarket unit that plugs into the system and keeps the steering wheel cantrols??does anyone know? I looked at the oem parts price list for this stuff and man it's really expensive. I'm hoping for a aftermarket that's compatable with what i have.

mrspeck 01-11-2013 08:54 PM

These sound systems! My new to me 98 750 has issues also. The drivers door 5.25 is a solid buzzing, but it is the only one. I tried replacing the speaker itself, the new one does the same thing. At this point I just left it unhooked so I at least have the tweaters there. Now, could this be the head unit, an amp, wiring in the speaker housing in the door? Any suggestions? The other three doors are fine and the back four spearker are toast...they crackle a lot. I have replacements on the way for them. Any help would be appreciated.

sinaiflash 01-11-2013 09:15 PM

I am lost and any advice i'd give you would be bad.

BMWFatherFigure 01-13-2013 09:54 AM

If the speaker buzzes it is getting something from the amp. Poss bad earths or bad terminations on speaker or amp wires. I have not had radio/audio problems yet........ Can a dealer/indy test the unit on the bench to eliminate problems??

sinaiflash 01-13-2013 11:05 AM

Sinaiflash
 
[SIZE="5"][FONT="Arial Black"]AS I'M SURE YOU'LL AGREE THE TEST IS NO BIG DEAL, IT'S GETTING THE COMPONENTS OUT OF THE CAR TO TEST. WHEN THESE DASHBOARDS AND TRIM ARE DISTURBED THEY ALMOST NEVER GO BACK INTO A TIGHT NO SQUEEK, RATTLE FREE FIT. SO I'M GOING TO ASK THE QUESTION AGAIN, IS THERE AN INSTRUMENT THAT THE DEALER WOULD HAVE THAT CAN TROUBLESHOOT THE AUDIO COMPONENTS ON THE 740 IL? OR ANY PLACES WHERE I MIGHT TAKE IT. I'M HOPING SOMEONE OUT THERE HAS HAD THESE PROBLEMS AND CAN HELP ME ELIMINATE THE DRAMA OUT OF DEALING WITH THIS. I USED TO HAVE A PORSCHE 928 AND I THOUGHT IT WAS REALLY EASY TO WORK ON AND IT DIDN'T HAVE ANY OF THESE BUILT IN PROBLEMS. I COULD NEVER UNDERSTAND THE APPEAL OF THE BMW UNTIL I GOT ONE, THEY TRULY ARE GREAT DRIVING CARS. A DREAM TO DRIVE WHEN THERE IS MUSIC. I'D REALLY APPRECIATE ANY HELP POINTING ME IN THE RIGHT DIRECTION. I JUST RECEIVED THE BENTLY SERVICE MANUAL, IT ONLY HAS A FEW PAGES RELATED TO THE AUDIO SYSTEM AND THE EXAMPLES ARE FROM A 2001 740 IL SO IT'S NOT AN APPLES TO APPLES COMPARISON TO MY 97 AND NOT MUCH IN THE WAY OF TROUBLESHOOTING HELP.

chrisn7 01-14-2013 08:15 AM

If there is no display at the monitor, this could be the nav unit, as this controls video, and will also overide a TV module, if present.

Generally, head unit failure is uncommon, the usual culprits are nav unit, DSP module, radio module.

Connections made or broken whilst driving are likely to be a loose plug or earth.

Radio modules, particularly BM54, are known for certain groups of circuit board soldered joints failing. There are pics of these around, and there are plenty of references to this issue if you search 'bmw BM54'

BMWFatherFigure 01-14-2013 08:54 AM

Try google 'e38 problems' some really useful links come up then.

chrisn7 01-14-2013 03:56 PM

Yep I should imagine that might give one or two results;)

sinaiflash 01-14-2013 08:13 PM

Thank you for your reply to my question

sinaiflash 01-14-2013 08:15 PM

Would some one explain to me the little box posting rules under the forum navigation.

darrelljr00 01-19-2013 12:02 PM

Hello..

Here is a YOUTUBE Video that I recorded that shows the noise that comes from my radio.. Please let me know what you think..

http://www.youtube.com/watch?v=TSb77...ature=youtu.be

sinaiflash 01-19-2013 04:26 PM

Sinaiflash
 
first dalejr00 i want to say what a great video you made. I am really lost as to what is wrong with my radio so me offering you any opinions would be like a blind man leading you. It sounds to me like some kind of feed back and if i were to offer an opinion and would not be accountable for it, i'd guess it was the amplifier. But like i said i'd be guessing. I can't get over what a great diagnostic tool that video is. My car does not have the screen that yours does. Let me know what you find. Where did you get the used parts you speak of in the video.


All times are GMT -7. The time now is 10:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms