Bimmerfest - BMW Forums

Bimmerfest - BMW Forums (http://www.bimmerfest.com/forums/index.php)
-   E63 / E64 6 Series (2003 - 2013) (http://www.bimmerfest.com/forums/forumdisplay.php?f=114)
-   -   Blank Screen (http://www.bimmerfest.com/forums/showthread.php?t=667072)

blakedanatural 12-30-2012 09:29 PM

Blank Screen
 
Hello All,
After driving all day I went back out for one more errand and the dash was blank. I turned the car off and restarted and the BMW insigna lit up but then the display went blank. No navi,radio or anything. I drive control justs spins around without the little stops in between. ( I hope I explained that right)
Anyway it sounds electronic. As always any help with be greatly appreciated before I make a appointment with the stealership. Going to check my extended warranty to see if any electronic malfunction is covered.

Thank you,
Blake

greco2000 12-30-2012 11:14 PM

Do a search. There is a way to reset your idrive. Something about holding down both eject buttons or something like that...

Mulchman 12-31-2012 03:53 AM

Hold down both eject buttons (CD/DVD) and push the volume/mute button.

blakedanatural 12-31-2012 05:04 PM

Hello Guys,
Talked to a tech and he says it could be the DVD DRIVE. Any comments

TxTaz 01-01-2013 12:42 PM

Quote:

Originally Posted by blakedanatural (Post 7281723)
Hello Guys,
Talked to a tech and he says it could be the DVD DRIVE. Any comments

Uhmmm yeah...NO!:) When the IDrive just spins it means no power to the car radio modules.

The IDrive reboot would not work if you don't have any power. It is a soft re-boot. (Meaning software)

Does the car start? Gauges move on the dash? Any noise from the CD or DVD drives?

If the cars runs and gauges work, your CCC is probably good.
- Check fuses, there are post about where they are located on the board.
- Next check the car radio system with a scanner to see if there are faults.
- Last (if it were me) pull the center console, screen and under the glove box. Check for power to the modules. If I remember, the radio module is a part of the CD/DVD.
Be careful, the orange cables are fiber and break easily.

Good luck,
Taz

blakedanatural 01-01-2013 03:00 PM

TxTaz,
Well I just did the soft reset. Everything looked like it was in running order. The idrive spinned when the screen was blank. Yes the car always started and ran like normal but the dash had went blank. All the other guages was working normal and was illuminated clearly. I am going to wait a couple of hours and go out there and start the car again. I don't want pull anything out cause I don't want to mess up those fiber cables you mentioned. I will keep you informed because I have a appointment with the dealer on Thursday. Hopefully things will correct itself before then.

Blake

msa9167 01-02-2013 04:54 PM

Had the same problem on my 05 a month after the warranty went out. It was the CCC Car Communication Computer. BMW fixed it under warranty as a good will fix. Had to pay $100, but it was better then the $800 if BMW wouldn't help me put.

Also there is a fuse that's behind the CCC u should check also.

blakedanatural 01-02-2013 07:14 PM

Wow! I hope my extended warranty covers me too if thats the problem. My appointment is tomorrow at 3pm. I talked to a indy tech and he mentioned that sometimes the module in the trunk gets wet. That may cause that problem too or moisture inside the console over the radio may get wet. Who knows but Ill find out tomorrow.

blakedanatural 01-02-2013 07:19 PM

MSA9167,
Where is the CCC located at? Is in the trunk?

Yorgi 01-02-2013 07:28 PM

Quote:

Originally Posted by blakedanatural (Post 7285636)
MSA9167,
Where is the CCC located at? Is in the trunk?

It's under the DVD drive.

Here is a pic. The DVD drive can be ordered separately.

Regmatc 01-02-2013 08:01 PM

Mine does that periodically too, but usually resets within 15 minute s of driving....just thought this was a normal electronic quirk with the 6er.

Sent from my SPH-L710 using Bimmer App

blakedanatural 01-02-2013 08:42 PM

Thanks Yorgi!

blakedanatural 01-02-2013 08:44 PM

The dealership is giving me a 2012 535 for a loaner. !

msa9167 01-03-2013 01:27 AM

4 Attachment(s)
It`s the cd/dvd drive that is in the middle of the dash. The last picture shows the yellow fuse that may have burn out.
Sent from my ASUS Transformer Pad TF300T using Bimmer App

All-Or-Nothing 01-03-2013 07:26 AM

Quote:

Originally Posted by Mulchman (Post 7280655)
Hold down both eject buttons (CD/DVD) and push the volume/mute button.


I never hold both eject buttons. I only hold the CD eject button and the power/mute button down until the CD ejects and the screen goes blank. Let go and the CD goes back in and iDrive reboots. :dunno:

blakedanatural 01-06-2013 02:42 PM

Hello all,
Sorry for the late reply but I also had a failed CCC. It was covered with the extended warranty and I had to pay 100.00 for the deductible. The actual charge was 1040.00. So my warranty came thru for once without the hassle. I tell you one thing I am so glad I invested in the extended warranty.

colink 01-06-2013 03:11 PM

Quote:

Originally Posted by blakedanatural (Post 7294271)
Hello all,
Sorry for the late reply but I also had a failed CCC. It was covered with the extended warranty and I had to pay 100.00 for the deductible. The actual charge was 1040.00. So my warranty came thru for once without the hassle. I tell you one thing I am so glad I invested in the extended warranty.

Which warranty company and level of coverage?

It's good to hear when they step up.

blakedanatural 01-06-2013 05:15 PM

CoLink,
GE Auto Warranty Services with the 4 star plus coverage. 100.00 deductible


All times are GMT -7. The time now is 05:17 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms